wangdeng 发表于 2008-8-16 11:55

求助:ASUS Wl-500w 刷機后設置過程中導致路由器不可用(已解决,谢谢!)

本來機器刷的是oleg的固件
但是看到DD-wrt有更新到SP1
所以就想試試這個新版本的固件
刷新的過程比較順利,使用ASUS的Firmware Restoration工具
刷機完成后進入web管理頁面,修改密碼,填入pppoe的賬號和密碼
然後將界面語言修改成簡體中文,保存
然後就在這個時候頁面停在http://192.168.1.1/apply.cgi
然後連接就斷掉。
路由器貌似死機,我就拔掉電源,想重啓
但是重啓后只有Power和插著網綫的那個Lan口的燈亮
AIR等其他燈都不亮了
Reset,不管是軟Reset還是使用30/30/30方式進行硬件的reset都沒有用
按住reset鍵,再插入電源,也不能進入恢復模式(Power燈不會閃爍)
奇怪的是再不插入任何網綫的時候,按住reset再插入電源,貌似是可以進入恢復模式(Power燈會閃爍),但是插入網綫后又會停止閃爍(退出恢復模式),所有的Lan口和WAN口插入網綫指示燈都可以亮起。

請版主幫忙診斷一下是什麽原因,有沒有什麽解決方法,不勝感激!

[ 本帖最后由 wangdeng 于 2008-8-17 14:40 编辑 ]

wangdeng 发表于 2008-8-16 13:21

請問有哪位達人能指點一下嗎?謝謝!!

qwea 发表于 2008-8-16 13:50

nvram出错了。呵呵。只有拆flash重写,或者用短接法了。

kim3013 发表于 2008-8-16 14:52

我也刚入手此路由,到底刷哪个版本呢?

fay1 发表于 2008-8-16 15:40

DDWRT支持ASUS硬复位的。 怎么不可以。 ASUS很难刷死的

wangdeng 发表于 2008-8-16 16:00

在网上找了一篇类似的帖子,用短接法的,

-------------
3、切断AP电源、查看FLASH芯片,打印口向下、指示灯向上,那么左上角的芯片就是FLASH芯片,我拆开的2台WL-500B的FLASH芯片都是AMD的AM29LV320DT,仔细观察这个芯片:左边从上至下的针脚定义是1-24脚,然后查找到第10脚,这个针脚旁边有一个数字“10”,在这个数字“10”的左边,有一个贴片电容,现在你需要用到一个尖尖的物体来短路第10针脚,方法是找一个尖镊子,然后镊子的一头接触到第10针脚上、另外一头接触到刚才说到的那个电容的左边(也就是远离第10针脚的一边),接触牢固后,插上电源,暂时不要放开镊子,注意观察电源灯,如果电源灯开始闪烁了,那么你可以松开镊子、继续下一步,如果没有闪烁、那么重复多次、直到电源灯闪烁;
-------------------

按照这种方法短接以后,四个Lan口的灯全亮,就是Power灯不亮。
估计是500w的flash的PIN与500g的pin不一样。

wangdeng 发表于 2008-8-16 16:04

Flash左边PIN脚放大图,已经有被我短接过的痕迹

[ 本帖最后由 wangdeng 于 2008-8-16 16:06 编辑 ]

wangdeng 发表于 2008-8-16 16:10

Flash右边的pin脚

wangdeng 发表于 2008-8-16 16:15

回复 #5 fay1 的帖子

是啊,我以前也有刷失败的经历,都可以在restore模式下面刷回来。
唯独这次出这种状况。
这个路由器在大陆卖的很贵1700人民币左右,我是在台湾花了2950块新台币买的,现在人还在台湾。
我也不准备送修了,就依靠各位的智慧,看能不能救回来,也为后来者提供一个参考。

fay1 发表于 2008-8-16 16:22

不同FLASH的针脚定义不同,建议你找下你这个FLASH型号的针脚定义, 有说明哪个针脚是短接的

fay1 发表于 2008-8-16 16:41

Asus WL500W
Same as Deluxe (Asus WL500G Deluxe).
Recover from bad flash via Asus Firmware Restoration.
Requires v24 RC3 or later
Thought a recap might help from an off the shelf installation December 2007. Similar to the Asus WL500G Deluxe setup (it's a touch redundant).


Tools:

laptop
RJ45 cable in box
Downloaded all the images and instructions.
    *wl500g-clear-nvram.trx wl500g-clear-nvram.trx
    *wl500g-recover.trx wl500g-recover.trx
    *   Assus Router Utilty UT_WL500W_3180
    *temporary DD-WRT firmware:dd-wrt.v24rc5_mini_asus.trx
    * actual final firmware image: dd-wrt.v24rc5_vpn_generic.bin (added the rc5 to filename when DL)
Process:
- remember to disable your wireless NIC, used the ethernet NIC
1. installed the utilties sofware on laptop Asus WL-500W wireless router utility,version 3.1.8.0
2. connected laptop to LAN port 1 with RJ45 cable
3. Booted up the router. DHCP seemed to work automatically. LAN connected.
4. Used the 'Asus Tools --> Device Discovery' application and doubleckicked on the router 'WL-500W' in the on screen box. It opens a new web page with the device menu options. May have to login as admin/admin.
5. (Skip this step) Used the onscreen menus to find the firmware update window. I was curious to see the actual Asus firware and the features like USB so I updated it to the newest version WL500W_1988. File is on the Asus website. You can skip this step. Reboot Router.
6. Changed my ethernet NIC to manual TCP/IP setting on the laptop: 192.168.1.10 (DHCP on asus won't work for next steps)
7. Make sure you can connect or see the router Ex. Asus Utilty --> Device Discovery or ping 192.168.1.1 should also work


The REAL work:
8. Unplug power cord from wl-500g.
9. Press and hold restore button and then insert power cord back into router.

    When the PWR light starts flashing, release Restore button.
    Now your wl-500g is in restore mode.

10. Run Asus Firmware Restoration (can be found on asus website, Router Utilities software or included CD). Asus Utility --> Firmware Restoration.
11. Choose the link wl500g-recover.trx file and also upload it to your router. Wait 2-3 minutes. NOTE I skipped the clear.trx image load and it worked for me. but if doesn't for you then look at the WL500G setup instructions. And Yes I used the wl500g images or trx files for this.
12. Unplug power and again enter Restore mode (steps 8 and 9)
13. Choose the firmware you wish to flash and upload with the Firmware Restoration utiltity. Wait 2-3 minutes. Reboot. I used the dd-wrt.v24rc5_mini_asus.trx image.
14. see if you are you able to connect to the router 192.168.1.1. Logon to DD-WRT web interface with root/admin.
15. Use DDR-WRTs web interface to upload the image e.g. dd-wrt.v24rc5_vpn_generic.bin
16. Voilà! Done. Reset your laptop's ethernet NIC to DHCP or automatically detect IP address.


Questions/Issues:


If you are getting error with the Firmware Restoration utility not finding the router (I could never get it to work), use the tftp upload method but follow the same instruction as above. Use a Windows tftp-client and run tftp -i 192.168.1.1 PUT file.trx.
After uploading, wait 3 min before pulling the power-cord and move to the next step.
Why would I use this router? I found Linksys 54GS/L were much easier to use and install. Cannot uprgrade the antennas without destroying the case..
- But the WL500W is still relatively cheap (under US$100 - Apr08), with 8M flash so you have a 4M jffs partition.
- To use the USB storage, after mounting jffs/cleanfs, follow instruction USB_storage. I got my 4G usb-key to work easily

wangdeng 发表于 2008-8-16 18:16

谢谢各位,问题解决了
短接Flash的第9PIN与地线(周围的铁壳子就是地)
再插入电源就可以进入恢复模式了。

qwea 发表于 2008-8-16 19:16

能贴一下,你的500w的cfe备份吗?

fay1 发表于 2008-8-16 21:02

原帖由 wangdeng 于 2008-8-16 18:16 发表 http://www.right.com.cn/forum/images/common/back.gif
谢谢各位,问题解决了
短接Flash的第9PIN与地线(周围的铁壳子就是地)
再插入电源就可以进入恢复模式了。


希望你能把FLASH短接图理下弄个图示,这样其他一样与你有问题的人就可以解决了,大家共同进步!

http://docs-europe.electrocomponents.com/webdocs/09a3/0900766b809a3615.pdf

这个是FLASH的DATASHEETS。

[ 本帖最后由 fay1 于 2008-8-16 21:27 编辑 ]

simemu 发表于 2008-8-17 10:44

楼主把尸体卖给我

awingbird 发表于 2008-8-17 10:59

ls回帖不看帖吗?
人家lz在12楼都说了。

谢谢各位,问题解决了
短接Flash的第9PIN与地线(周围的铁壳子就是地)
再插入电源就可以进入恢复模式了。

wangdeng 发表于 2008-8-17 14:47

原帖由 qwea 于 2008-8-16 19:16 发表 http://www.right.com.cn/forum/images/common/back.gif
能贴一下,你的500w的cfe备份吗?


不好意思,我不太会弄这个备份,我要怎样帮你取得这个备份呢?

kim3013 发表于 2008-8-17 21:07

回复 #17 wangdeng 的帖子

哈哈,刚才我也碰到了,不过把连接的移动硬盘拔了,电源拔了,等会儿再插电源就恢复了

micalchan 发表于 2008-8-23 22:29

我在香港买的,上次也刷坏了,5灯全亮,然后再插电源就没反应了。 拼了把,送ASUS上海维修点,他们也没看出来是港行,收下来了。不过第2天打电话告诉我是好的,我过去看,确实是我刷进去的DD WRT界面。奇怪。就这样活过来了。 下次再坏再送修,反正保2年的

AHQIU 发表于 2008-9-11 17:11

想买这个路由器.问一下支不支持tomato?
听说原厂的firmware也不错.可不可以证实这一点?
页: [1] 2
查看完整版本: 求助:ASUS Wl-500w 刷機后設置過程中導致路由器不可用(已解决,谢谢!)