设为首页收藏本站

恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
小博无线
查看: 89160|回复: 97

Openwrt高级应用之5:mwan3来宽带叠加

    [复制链接]
发表于 2013-6-5 21:12 | 显示全部楼层 |阅读模式
本帖最后由 pupie 于 2013-6-15 00:58 编辑

以楼主所在地,可以双拨,超过2拨后就很难拨上,需要修改pppd,这个放在以后讨论。这个帖子教大家如何用mwan3 宽带叠加。淘汰掉老旧的软件。
本例以 opoenwrt 12.09正式版为例,原软件来自openwrt 英文论坛: https://forum.openwrt.org/viewtopic.php?id=39052

0. 编译安装:
修改编译根目录的 feeds.conf.default
增加:
src-git mwan git://github.com/Adze1502/mwan.git

更新源:
./scripts/feeds update -a
./scripts/feeds install -a
make menuconfig 选择mwan3 和  mwan3 luci app

编译:
make package/mwan3/compile -j 6 V=99

make package/mwan3-luci/compile -j 6 V=99




1. 设置network增加一个wan,可以在luci中设置。或者直接修改/etc/config/network. 楼主这里是pppoe 双拨为例子,如果是其他接入请自行修改配置。需要注意的是 两个接口都要加入 metric 选项 并且数值不能一样

config interface 'wan'
        option ifname 'eth0.2'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username 'username'
        option password 'password'
        option metric '10'

config interface 'wan2'
        option proto 'pppoe'
        option ifname 'eth0.2'
        option username 'username'
        option password 'password'        option metric '20'





2. 修改 /etc/config/firewall,增加规则,大部分是套用默认openwrt设置,把wan2接口加入防火墙wan区
config defaults
    option syn_flood    1
    option input        DROP
    option output        ACCEPT
    option forward        REJECT

config zone
    option name        lan
    option network        'lan'
    option input        ACCEPT
    option output        ACCEPT
    option forward        REJECT

config zone
    option name        wan
    option network        'wan wan2'
    option input        REJECT
    option output        ACCEPT
    option forward        REJECT
    option masq        1
    option mtu_fix        1

config forwarding
    option src        lan
    option dest        wan


3. 重启网络,防火墙服务
/etc/init.d/network restart
/etc/init.d/firewall restar

4. 编辑 mwan3 配置
贴出我的配置,其实用默认即可,把wan1,wan2 负载平衡的规则放在最上面就行了。注意我这里用的是8.8.8.8 当做端口检测IP,mwan会不断ping这个IP看回应判断是否down


config rule
        option dest_ip '0.0.0.0/0'
        option use_policy 'wan1_wan2_loadbalanced'
        option proto 'all'
        option equalize '1'

config rule
        option dest_ip '192.168.0.0/16'
        option proto 'tcp'
        option use_policy 'default'

config rule
        option src_ip '192.168.1.0/24'
        option proto 'tcp'
        option dest_port '563'
        option use_policy 'wan2_only'

config rule
        option proto 'tcp'
        option dest_port '995'
        option use_policy 'wan1_only'
        option src_ip '192.168.1.0/24'

config rule
        option dest_ip '88.154.0.0/16'
        option proto 'tcp'
        option dest_port '1024:65535'
        option equalize '1'
        option use_policy 'wan1_wan2_loadbalanced'

config rule
        option dest_ip '77.11.41.0/24'
        option proto 'tcp'
        option dest_port '1024:65535'
        option use_policy 'wan1_pri_wan2_sec'

config rule
        option dest_ip '112.136.0.0/16'
        option proto 'udp'
        option dest_port '5352'
        option use_policy 'wan2_pri_wan1_sec'

config interface 'wan'
        option enabled '1'
        list track_ip '8.8.8.8'
        option reliability '1'
        option count '1'
        option down '3'
        option interval '10'
        option up '3'
        option timeout '3'

config interface 'wan2'
        option enabled '1'
        list track_ip '8.8.8.8'
        option reliability '1'
        option count '1'
        option down '3'
        option interval '10'
        option up '3'
        option timeout '3'

config member 'wan1_m1_w3'
        option metric '1'
        option weight '3'
        option interface 'wan'

config member 'wan1_m2_w3'
        option metric '2'
        option weight '3'
        option interface 'wan'

config member 'wan2_m1_w2'
        option interface 'wan2'
        option metric '1'
        option weight '2'

config member 'wan2_m2_w2'
        option interface 'wan2'
        option metric '2'
        option weight '2'

config policy 'wan1_only'
        list use_member 'wan1_m1_w3'

config policy 'wan2_only'
        list use_member 'wan2_m1_w2'

config policy 'wan1_wan2_loadbalanced'
        list use_member 'wan1_m1_w3'
        list use_member 'wan2_m1_w2'

config policy 'wan1_pri_wan2_sec'
        list use_member 'wan1_m1_w3'
        list use_member 'wan2_m2_w2'

config policy 'wan2_pri_wan1_sec'
        list use_member 'wan1_m2_w3'
        list use_member 'wan2_m1_w2'



5.  启用mwan3

/etc/init.d/mwan3 enable
/etc/init.d/mwan3 restart

或者干脆重启路由器,拨号,只到2个network 接口都拨号上注意,mwan3,在接口的网关相同的情况下,无法工作,所以拨号的时候,两个接口IP地址不在同一个网段

6.迅雷/BT试试速度吧
12M光纤双拨目测效果良好

QQ图片20130605200200.jpg


附件:
20130605 mwan3最新英文版,几个小时之前github上更新了。包括mwan3 和mwan 的luci程序,安装的时候咸先装mwan3,再装mwan3的luci程序。不要怀疑,5分钟前才编译,这是最新的编译!别找我要中文版,要折腾openwrt,先学好英文。
mwan3_1.2-10_all.rar (5.26 KB, 下载次数: 709)

评分

参与人数 3恩山币 +5 收起 理由
siasjack + 1 好贴 收藏了!
龙吟之耀 + 1 丁锦昊到此一游!
jzmno1 + 3 土豪,我们做朋友吧!

查看全部评分

本帖被以下淘专辑推荐:

我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-6-6 08:44 | 显示全部楼层
支持楼主。不过编译的是哪个路由的呀?
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-6-6 08:50 来自手机 | 显示全部楼层
谢谢楼主的分享!
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-6-6 09:00 | 显示全部楼层
这个模块默认就双拨的。只要虚拟出wan1\wan2,并且拨号成功,不需要设置就叠加。前几天就有兄弟发布了。值得探讨的是超过2拨,比如4拨。。。。甚至于10拨。。。。

早上浏览了一下楼主发的英文论坛,确实有人在研究4拨,而且成功。只能回家去试试看。发觉老外蛮有意思的,哈哈。。。。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-6-9 21:55 | 显示全部楼层
请问楼主,mwan3是否需要先安装macvlan?
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2013-6-10 13:31 | 显示全部楼层
4拨很简单,netowkr中配置4个接口,在学着原配置文件配置4个接口相关策略即可。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-6-13 20:37 | 显示全部楼层
支持LZ
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-6-14 16:33 | 显示全部楼层
本帖最后由 tyx776 于 2013-6-14 17:27 编辑

石像鬼可以用吗?ORZ装上配置好了,但就是拨不上。估计是不支持了
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-6-14 22:34 | 显示全部楼层
本帖最后由 lyin 于 2013-6-14 22:36 编辑

QQ图片20130614221044.jpg

折腾几天 按楼主的教程终于用nwan3带宽叠加了,我这里也是电信12M的光纤,可以稳定3拨,唯一遗憾的是nwan3只能叠加2拨的速度,说下我用的是4530自改16Mflash,用的论坛 shenrui01 网友源码自己编译的,在这里谢谢shenrui01发布的源码,同时感谢 pupie 贡献那么好的教程。 想用 shenrui01 的源码自己编译DIY的  猛点这里
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-6-14 22:54 | 显示全部楼层
lyin 发表于 2013-6-14 22:34
折腾几天 按楼主的教程终于用nwan3带宽叠加了,我这里也是电信12M的光纤,可以稳定3拨,唯一遗憾的是nw ...

成功的估计都是自己的线路吧。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-6-18 23:00 | 显示全部楼层
我特别想知道,你这个配置是哪一个机型使用的,还是通用!!
只需要一个wan口还是N个wan口

点评

通用,N个WAN口,请见network配置,玩openwrt需要具备基本的linux知识  发表于 2013-6-19 09:59
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-6-19 13:14 来自手机 | 显示全部楼层
4530    单线多拨
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-6-19 17:06 | 显示全部楼层
mwan和nwan有何区别,哪个好用些?
貌似op现有的固件大多数都是用nwan作为多拨工具
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-7-21 12:06 来自手机 | 显示全部楼层
学习学习,谢谢大家分享。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-8-7 16:16 | 显示全部楼层
本帖最后由 zrrx 于 2013-8-7 16:35 编辑
pupie 发表于 2013-6-10 13:31
4拨很简单,netowkr中配置4个接口,在学着原配置文件配置4个接口相关策略即可。


请问如果只能并发多发是否使用?
4拨的策略配置能否举例说明?谢谢。
比如config policy 'wan_wan2_wan3_wan4_wan5_wan6_loadbalanced'
怎么配置?
我的恩山、我的无线 The best wifi forum is right here.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|恩山无线论坛 ( 苏ICP备05084872号-1 )  

GMT+8, 2018-9-19 01:29

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表