设为首页收藏本站

恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
小博无线
楼主: shenyz

mwan3 luci 单线多拨 支持相同网关

    [复制链接]
发表于 2013-12-6 23:05 | 显示全部楼层
都是神人,我是望神兴叹
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-12-7 13:15 | 显示全部楼层
并发多拨不能成功识别,期待改进~~~
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-12-8 15:32 | 显示全部楼层
要好好学习哈
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-12-9 23:16 | 显示全部楼层
shenyz 发表于 2013-11-25 08:20
很好,上个图看看呢

上神马图??

对了LZ我想问你个问题:我发现访问网站的时候速度特别慢,一开始我以为是我设置问题。
期间换了好几个OPENWRT版本还是不行!

但是只要不多拨就没神马问题,我还搞了DNS跳转也是这个问题,实在搞不定才上来问问,不知道LZ有没遇到这个问题?但是我尝试了一下把叠加的软件包换成MULTIWAN就好不少,但是还是也别慢?

不知道是不是要建策略的关系还是哪里的设置问题?望LZ能回答一下,感谢!
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2013-12-10 08:23 | 显示全部楼层
liusimin 发表于 2013-12-9 23:16
上神马图??

对了LZ我想问你个问题:我发现访问网站的时候速度特别慢,一开始我以为是我设置问题。

我的一切正常啊!
我nwam3配置:
# This is a mwan3 example config. For mwan3 to work you will need at least:
#
# - 2 interfaces
# - 2 members
# - 1 policy
# - 1 rule
#
# First define all your wan interfaces. Interface name must match with the
# name used in your network configuration:
config interface 'wan1'
option enabled '1'
option reliability '1'
option count '1'
option timeout '2'
option interval '60'
option down '3'
option up '5'
list track_ip '114.114.114.114'
list track_ip '58.216.114.245'
list track_ip '222.185.173.145'
list track_ip '222.184.115.137'
       option 'reroute' '1'
config interface 'wan2'
option enabled '1'
option reliability '1'
option count '1'
option timeout '2'
option interval '60'
option down '3'
option up '5'
list track_ip '114.114.114.114'
list track_ip '58.216.114.245'
list track_ip '222.185.173.145'
list track_ip '222.184.115.137'
       option 'reroute' '1'
config interface 'wan3'
option enabled '1'
option reliability '1'
option count '1'
option timeout '2'
option interval '60'
option down '3'
option up '5'
list track_ip '114.114.114.114'
list track_ip '58.216.114.245'
list track_ip '222.185.173.145'
list track_ip '222.184.115.137'
        option 'reroute' '1'
config interface 'wan4'
option enabled '1'
option reliability '1'
option count '1'
option timeout '2'
option interval '60'
option down '3'
option up '5'
list track_ip '114.114.114.114'
list track_ip '58.216.114.245'
list track_ip '222.185.173.145'
list track_ip '222.184.115.137'
       option 'reroute' '1'

# Next define a member and configure metric and weight values for this member.
# Each interface can have multiple member definitions. Give each member a correct
# name (A-Z, a-z, 0-9, "_" and no spaces).
config member 'wan1_1'
option interface 'wan1'
option metric '1'
option weight '1'
config member 'wan2_2'
option interface 'wan2'
option metric '1'
option weight '1'
config member 'wan3_3'
option interface 'wan3'
option metric '1'
option weight '1'
config member 'wan4_4'
option interface 'wan4'
option metric '1'
option weight '1'
# After that create a routing policy. A routing policy consist of one or more
# members. Give each policy a correct name (A-Z, a-z, 0-9, "_" and no spaces). You
# can create multiple policies, so that it is possible for different traffic to
# have different primary and/or backup interfaces.
config policy 'loadbalanced'
list use_member 'wan1_1'
list use_member 'wan2_2'
list use_member 'wan3_3'
list use_member 'wan4_4'

# And to finish the config define your traffic rules. Rules are matched in top to
# bottom order. If you define a rule and it matches, all following rules are ignored.
#
# If the option equalize is set, mwan3 will load-balance each new session to the same
# host. If not set, it will load-balance based on destination.
config rule 'Rule'
option proto 'all'
option use_policy 'loadbalanced'
option equalize '1'



network配置
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 2 3 4 5'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0t 1'

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd6c:dd5d:96fc::/48'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.199.1'

config interface 'wan1'
option ifname 'eth0.2'
option proto 'pppoe'
option username 'xxxx'
option password 'xxxxx'
option metric '10'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'

config interface 'wan2'
option proto 'pppoe'
option ifname 'vth2'
option username 'xxxxx'
option password 'xxxxx'
option metric '20'

config interface 'wan3'
option proto 'pppoe'
option ifname 'vth3'
option username 'xxxxxx'
option password 'xxxxx'
option metric '30'

config interface 'wan4'
option proto 'pppoe'
option ifname 'vth4'
option username 'xxxxx'
option password 'xxxx'
option metric '40'
QQ截图20131210081306.png
QQ截图20131210081329.png
QQ截图20131210081341.png
QQ截图20131210081351.png
QQ截图20131210081403.png
QQ截图20131210081557.png

我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-12-10 11:11 | 显示全部楼层
并发多播改天试试~
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-12-10 20:34 | 显示全部楼层
shenyz 发表于 2013-12-10 08:23
我的一切正常啊!
我nwam3配置:
# This is a mwan3 example config. For mwan3 to work you will need ...

配置几乎都一样,这个问题对于手机联网开网页尤其明显!

但是不开启MWAN3单拨就好着呢,我真是奇了怪了!
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2013-12-10 21:14 | 显示全部楼层
liusimin 发表于 2013-12-10 20:34
配置几乎都一样,这个问题对于手机联网开网页尤其明显!

但是不开启MWAN3单拨就好着呢,我真是奇了怪 ...

openwrt你用的是什么版本,我用的是最新的trunk版,12.09我测试下来好像不咋地
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-12-10 21:38 | 显示全部楼层
shenyz 发表于 2013-12-10 21:14
openwrt你用的是什么版本,我用的是最新的trunk版,12.09我测试下来好像不咋地

捕获.JPG
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-12-10 21:41 | 显示全部楼层
shenyz 发表于 2013-12-10 21:14
openwrt你用的是什么版本,我用的是最新的trunk版,12.09我测试下来好像不咋地

3.10.21的trunk版

12.09更是差得远了!

现在只有在DNS和DHCP指定了DNS稍微好了一点点!

可是打开网站还是慢到一种境界了!

但下载速度挺好,几乎达到了150M无线网络的极致.....
捕获.JPG

我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-12-10 21:48 | 显示全部楼层
shenyz 发表于 2013-12-10 21:14
openwrt你用的是什么版本,我用的是最新的trunk版,12.09我测试下来好像不咋地

IPTABLES的防火墙NAT映射语法我是这么写的:
如果不加IPTABLES用默认的防火墙语法效率极差,使用SPEED测速始终都是在1M/S说话!

我把默认的防火前规则全部删除了都是手动添加,最新版本的IPTABLES也全部自己编译好装上去了!

捕获.JPG





touch /var/lock/subsys/local
#!bin/bash

echo""
echo""
echo""
echo""
echo "                            Welcome use liusimin net route"
echo""
echo""
#dhcpd eth0
/sbin/modprobe ip_tables
/sbin/modprobe ip_nat_ftp
/sbin/modprobe ip_conntrack_ftp

echo""
echo""
echo "             1.      Clear IPTABLES .....                        [OK]"

/sbin/iptables -F
/sbin/iptables -F -t nat
/sbin/iptables -X
/sbin/iptables -Z
/sbin/iptables -P INPUT ACCEPT
/sbin/iptables -P FORWARD ACCEPT
/sbin/iptables -P OUTPUT ACCEPT


echo""
echo""
echo""
echo "             2.      Open Eth0.1.ppp0 ...... ipv4                   [OK] "

echo 1 > /proc/sys/net/ipv4/ip_forward


echo""
echo""
echo""
echo "             3.      Open Ip_Forward .....                       [OK] "

#/sbin/iptables -A FORWARD -s 192.168.0.1/255.255.255.0 -j ACCEPT
#/sbin/iptables -A FORWARD -s 192.168.1.1/255.255.255.0 -j ACCEPT
#/sbin/iptables -A FORWARD -s 192.168.2.1/255.255.255.0 -j ACCEPT
#/sbin/iptables -A FORWARD -s 192.168.3.1/255.255.255.0 -j ACCEPT
#/sbin/iptables -A FORWARD -s 192.168.4.1/255.255.255.0 -j ACCEPT
/sbin/iptables -A FORWARD -s 0/0 -d 0/0 -j ACCEPT

echo""
echo""
echo""
echo "             4.      Open Forward OK .....                       [OK] "

#/sbin/iptables -t nat -A POSTROUTING -o eth1 -s 192.168.0.1/255.255.255.0 -j MASQUERADE
#/sbin/iptables -t nat -A POSTROUTING -o eth1 -s 192.168.1.1/255.255.255.0 -j MASQUERADE
#/sbin/iptables -t nat -A POSTROUTING -o eth1 -d 192.168.0.1/255.255.255.0 -j MASQUERADE
#/sbin/iptables -t nat -A POSTROUTING -o eth1 -d 192.168.1.1/255.255.255.0 -j MASQUERADE
#/sbin/iptables -t nat -A POSTROUTING -o eth1 -s 192.168.2.1/255.255.255.0 -j MASQUERADE
#/sbin/iptables -t nat -A POSTROUTING -o eth1 -s 192.168.3.1/255.255.255.0 -j MASQUERADE
#/sbin/iptables -t nat -A POSTROUTING -o eth1 -s 192.168.4.1/255.255.255.0 -j MASQUERADE
#/sbin/iptables -t nat -A POSTROUTING -o eth1 -d 192.168.2.1/255.255.255.0 -j MASQUERADE
#/sbin/iptables -t nat -A POSTROUTING -o eth1 -d 192.168.3.1/255.255.255.0 -j MASQUERADE
#/sbin/iptables -t nat -A POSTROUTING -o eth1 -d 192.168.4.1/255.255.255.0 -j MASQUERADE

/sbin/iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE


echo""
echo "             6.      Open Firewall .....                         [OK]  "

echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_all
iptables -A FORWARD -p tcp --syn -m limit --limit 1/s -j ACCEPT
iptables -A FORWARD -p tcp --tcp-flags SYN,ACK,FIN,RST RST -m limit --limit 1/s -j ACCEPT
iptables -A FORWARD -p icmp --icmp-type echo-request -m limit --limit 1/s -j ACCEPT
#echo "1">/proc/sys/net/ipv4/conf/eth1/proxy_arp
#echo "1024">/proc/sys/net/ipv4/neigh/default/gc_thresh1
#echo "2048">/proc/sys/net/ipv4/neigh/default/gc_thresh2
#echo "4096">/proc/sys/net/ipv4/neigh/default/gc_thresh3

#                     ip ping boob firewall


#/sbin/iptables -A INPUT -p icmp -m limit --limit 6/m --limit-burst 5 -j ACCEPT
#/sbin/iptables -P INPUT DROP
#route del -net 169.254.0.0 netmask 255.255.0.0 dev eth1


echo""
echo""
echo " @@ IP: [192.168.0.* / 255.255.255.0] --- [192.168.4.* / 255.255.255.0] @@ "
echo""
echo""
echo""
echo""
echo "                                                  2013.12.07  "
echo""
echo""
echo "{&&         Email:[email protected]  && QQ:232930100




我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2013-12-11 08:31 | 显示全部楼层
liusimin 发表于 2013-12-10 21:41
3.10.21的trunk版

12.09更是差得远了!

http指定出口试试
QQ截图20131210081341.png
QQ截图20131211082951.png
我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-12-11 09:08 | 显示全部楼层
shenyz 发表于 2013-12-11 08:31
http指定出口试试

整整 用了一晚上时间,用笨办法试出来了!(每个参数都改一下反复试!折腾S我了

原来是WMM要关掉就好了!!!

我最后关闭了无线用有线挂上了原来的网件R6300无线路由当二级路由就没这个问题!

还有就是如果手动指定添加防火墙需要附件参数,映射80端口就好了。。。。。。
捕获.JPG 2.JPG

我的恩山、我的无线 The best wifi forum is right here.
发表于 2013-12-11 09:16 | 显示全部楼层
本帖最后由 liusimin 于 2013-12-11 09:21 编辑
shenyz 发表于 2013-12-11 08:31
http指定出口试试

谢谢LZ不厌其烦帮忙分析解决推理问题!!!

这下就完美了

最后说下这个的经验总结好了:DNS服务器指定静态DNS服务器地址开启DNSMASQ

开启了DNSMASQ以后DHCP/DNS里面的参数大部分对勾都不要点!

特别是: 【丢弃RFC1918上行响应数据】和【 允许127.0.0.0/8回环范围内的上行响应,例如:RBL服务】这两项!

下来就是删除默认防火墙手动更改添加,MWAN3里面不做变动还是用LZ说的这种设置!

加入CRONTAB计划任务每三个小时重起一下MWAN3,MTU改1492端口重获取IP地址每12小时自动重新获取一次(否则会出现其他虚拟VTH没有流量的问题)

使用TRACERTROUTE反向查询上级网关后添加路由跳数110  90 25.......(根据运营商上级路由的协议指定路由跳数,比如我的上级路由协议是OSPF  RIP EIGRP)
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2013-12-11 10:56 | 显示全部楼层
本帖最后由 shenyz 于 2013-12-11 11:01 编辑
liusimin 发表于 2013-12-11 09:16
谢谢LZ不厌其烦帮忙分析解决推理问题!!!

这下就完美了

恭喜,你很有折腾精神

我不知道你用的是什么牌子的路由器
我的tplink 1041n 改机16M 64M就没有这样的问题
wmm是无线路由器针对语音这一块的qos,上次也看到板块里面有的人有这样的现象,关闭它就好了。
我的恩山、我的无线 The best wifi forum is right here.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|恩山无线论坛 ( 苏ICP备05084872号-1 )  

GMT+8, 2018-9-20 08:32

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表