设为首页收藏本站

恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 149576|回复: 1349

【2016-05-12】 更新-- autoap 自动切换中继信号插件--支持LUCI界面配置

    [复制链接]
发表于 2015-8-5 12:11 | 显示全部楼层 |阅读模式
本帖最后由 d_link 于 2016-5-18 08:51 编辑

时隔半年有多,趁有点时间,更新一下。
此软件的初衷是楼主上网的方式主要是通过中继别人的网络(请轻拍),自己再建立一个信号作为AP来使用。众所周知,中继需要信号质量好,稳定,所以楼主把路由放在天花上面,长时间使用发现问题了:上级路由晚上会关机,或突然不能上网了,这时连自己的AP信号都一起消失,这时只能爬上去连根网线下来通过有线连接来切换信号。总是换来换去,爬来爬去。。。于是此插件就出来了.

若在安装或使用过程遇到问题,请将详细步骤过程贴出来,才能分析问题。否则,不作回复。
若是使用过程出现问题,把软件的调试信息【/tmp/autoap.log】和配置文件【/etc/config/autoAP  /etc/config/wireless】内容贴出来或PM我,(可以把ssid等隐私信息P掉)才知道出什么问题的。
若没以上信息作为参考,恕不回复,请见谅。 若我没及时回复,也请见谅,毕竟时间问题,我没法经常上论坛。



废话说多了。下面简单说一下此插件:


1、此工具主要是通过PING来测试网络的通断检测,如果PING结果不符合你期望,结合信号当前优先级与当前信号列表自动切换下一个最优中继信号。


2、此工具可以通过LUCI来进行配置,这里最好选的是中文,因为LZ英文水平有限,表达没中文好;


待续。。。

鉴于有人不清楚配置方法,我还是简单说一下吧:



安装:
下载附件,需要下载对应平台,高通方案请下载带AR字样,MTK或ralink的请下载带ramips的。。。
BCM的暂没硬件测试过,如有需要再看。
下载完毕解压出ipk,上传到路由(最好/tmp目录,什么,不知道怎样上传?TFTP..WINSCP。。等都可以),ssh或者telnetl登陆路由,cd 到上传目录,执行安装命令:
opkg install xxxx.ipk

当看到:
Installing luci-app-autoap (1.3.0_20160510_beta) to root...
Configuring luci-app-autoap.
Enabling rc.d symlink for autoAP
[[email protected]:/tmp]#
安装完毕。(目前在AA BB CC的AR固件上安装测试过, K1 pandorbox固件上安装测试过,其他固件请自测)


登录web,网络卡上会出现“中继增强”一项(目前只在普通openwrt固件测试过,若是其他类型固件,可能没有此菜单):

enter.png

是它了,点进去。

若是刚安装完首次运行,建议不要把首次运行的勾去掉,因为首次运行不止是配置以下两项,还涉及到防火墙等初始化:
firstrun.png


网页上有些时间的参数就不多说了,应该都看得懂。

这时,请先保存应用再进行信号扫描填写操作。

下面是扫描按钮,可以直观观察周围信号的各详细信息(需要配置好上面中继网卡对应的radio设备后保存应用再扫描):

scanbutton.png

中继信号填写更加方便, 能直接选择扫描出来的信号(也是需要配置好上面中继网卡对应的radio设备后保存应用再扫描),nil表示隐藏信号,这时可以通过选最底的--自定义--来手动填上隐藏的信号的SSID:
scan.png

SSID的“+”就不要点了,

include.png

此“+”是可以去掉,但要改系统的一个js文件的函数,反正无影响,我也没(懒)动(我自己的就手动改了)
noinclude.png



LUCI全貌:

1.JPG

2.JPG

3.JPG

4.JPG




功能:
1、总开关来决定程序是否运行;
2、可以配置的诊断域名;填上一个稳定的域名很重要,否则会因诊断失败而不断切换;
3、可以配置各诊断时期的时间;
4、可以配置指定的诊断网卡;方便有些人是叠加上网,有线没断,无线断了也能切换;
5、可以手动强制切换到指定信号;正在使用的信号网速很差,LZ我想切换到一个网速好点的信号。
6、可以修改一些基础配置;例如内网网段,自己使用的AP的SSID等;
7、目前最大支持64个中继信号;应该够了吧?

2015-08-12
更新:新增ralink平台(HG255D上测试过),由于没有编译MTK平台的SDK,MTK7620可以试试这个。


----------------------------------------------------------------------------------------
2015-09-11
1、改善WIFI配置部分,完美支持MT7620;
2、增加平均延时控制和丢包百分比控制;
3、中继信号增加IP方式可配;
4、增加多一个网站来保证诊断结果合理性;
5、改善WIFI配置部分,双频部分不再受影响,暂不支持5G中继切换
6、双无线叠加情况下,目前只支持在WIFI配置文件中第一个中继信号切换,第二个中继信号程序不处理。
7、网页上增加扫描按钮,可以手动扫描周围信号,帮助填写。

----------------------------------------------------------------------------------------
2015-10-14
1、修正双频配置可能存在切换失败问题(国庆测试发现)
2、信号填写能选择周围信号;

2016-05-12
1、根据填写信号优先级来循环选择最优信号;
      全局有个优先级步进,每个信号都有个初始优先级,当当前信号失效,发生切换时候,失效信号优先级将动态调整(自动增加步进值,例如失效前是2,步进是3,失效时候此信号优先级变成5),这时会进行信号扫描动作,优先级最小且在线的信号将会被使用。
2、若循环几次(可配)仍无法成功中继上网,将停止中继,退出插件,并放出AP信号供登录(即当前的AP);
3、修复潘多拉固件搜索信号问题。



潘多拉若安装不成功,可以试试在3楼说的方法去安装,安装完需要运行以下命令才能开机自启动:
/etc/init.d/runAutoAP enable

最后附上ipk安装文件(我就不隐藏了,觉得好用就支持一下吧)


luci-app-autoap_1.3.0_20160517_beta_ar71xx.rar (18.95 KB, 下载次数: 1355)

点评

AR2317不支持,请发一个  发表于 2017-2-16 19:16
楼主看到联系我,有事找你  发表于 2017-2-1 22:02
请问楼主哪里有源码下载?  发表于 2017-1-20 09:52
LEDE版本固件不支持,需要楼主编译基于musl的版本.  发表于 2016-12-14 09:43
HG255D固件DreamBox20120828【trunk+svn】 Collected errors: *satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-autoap: *libc*libuci *opkg_install_cmd: Cannot install p   发表于 2016-9-5 01:52
按手动安装步骤已成功装上,不过貌似初始化配置对路由器无任何作用,即使选中了“再次配置”,也不会作任何修改,这个怎么解毒。  发表于 2016-5-24 12:20
Lux
反馈一个问题,有个信道为12的信号在AutoAP页面,点“Scan”搜不到,手动改了无线里面的设置地区为"US"也还是搜不到  发表于 2016-4-8 22:54
期待楼主下一次更新支持MT7628,目前在潘多拉里连搜索信号都出错。  发表于 2015-12-4 23:39
重申:软件只协助中继信号切换,若中继信号均失效,自建的AP信号也是无法搜索到的,否则我不会做这个软件。 希望加个功能:中继失败了,就关闭中继,然后不就可以访问ap了么。。。  发表于 2015-11-17 14:54
7620刷潘多拉不能安装,提示:Unknown package 'luci-app-autoap'. Collected errors: * pkg_hash_fetch_best_installation_candidate: Packages for luci-app-autoap found, but incompatible with the architec   发表于 2015-9-13 08:31
完美支持7620,谢谢大神  发表于 2015-9-11 16:51
期待7620测试  发表于 2015-8-21 15:20

评分

参与人数 48恩山币 +70 收起 理由
lurixian + 1 支付宝已转500w给你!
丁豆丁 + 1 Happy New Year!
a7077447 + 1 谢谢分享
regedit110 + 1 强大的恩山!(以下重复1万次)
xiaoboy + 3 路过也要给楼主加个分
long1983 + 1 我来恩山就是为了看你!
sedna + 1 泥马,真给力,我要顶!
osos + 1 一看就是觉得高端、大气、上档次!
kinvcgs + 1 泥马,真给力,我要顶!
qjj1966 + 1 强大的恩山!(以下重复1万次)
zshwq5 + 1 呐,做人呢,最重要的就是开心
FX5000 + 3 呐,做人呢,最重要的就是开心
hkvsak123 + 1 博主的源码能公开下吗?想自己编译。。
lwqlwq + 1 亲,你太牛逼了,走,我请你吃鳇鱼头去~~~
virus1999 + 1 楼主威武—我就想问问挖掘机技术哪家强?
lizhendong + 1 亲,你太牛逼了,走,我请你吃鳇鱼头去~~.
jidongliu + 1 请楼主能够增加BCM63XX平台,确实有需要!
3ax31a + 1 亲,你太牛逼了,走,我请你吃鳇鱼头去~~.
wulishui + 1 亲,你太牛逼了,走,我请你吃鳇鱼头去~~~
爱会回来 + 3 亲,你太牛逼了,走,我请你吃鳇鱼头去~~~
ktm858 + 1 泥马,真给力,我要顶!
jianqiumy + 1 强大的恩山!(以下重复1万次)
Lux + 1 切糕党手持切糕刀强势围观楼主!
duyb1120 + 1 亲,你太牛逼了,走,我请你吃鳇鱼头去~~~
wukaisky + 1 谢谢楼主分享。
yajeed + 3 一看就是觉得高端、大气、上档次!
北极的冰山 + 1 一看就是觉得高端、大气、上档次!
wei209 + 1 又更新了?多谢多谢
cnafj + 1 呐,做人呢,最重要的就是开心
707241681 + 1 我有更好的想法,不知道楼主是否原因动手。搜索到1号wifi上线就自动切换回1号wif;不停.
mk-link + 1 一看就是觉得高端、大气、上档次!
remenbo + 1 一看就是觉得高端、大气、上档次!
xieboxuan + 1 一看就是觉得高端、大气、上档次!
冷意灰心 + 3 城会玩
cukkk + 1 强大的恩山!(以下重复1万次)
fybgl + 3 一看就是觉得高端、大气、上档次!
llg + 1 楼主威武—我就想问问挖掘机技术哪家强?
6331805 + 5 城会玩
rockze + 1 7620刷潘多拉不能安装,提示:Unknown package 'luci-app-autoap'. Collected errors:.
505554673 + 1 我是来打酱油的,老婆说酱油要涨价了,顺便再买两块豆腐~
sztd + 1 谢谢分享
l256 + 3 这个太好了。Tomato DualWAN下能有就好了!!WHR-HP-G125信号好,可惜没OPENWRT
e6656 + 3 泥马,真给力,我要顶!
jyxctg + 1 希望楼主能能搞个DDWRT版的!
q155128 + 1 期待更强大的新版本7620cpu
小泽武藤空 + 1 怀揽白富美的屌丝露出了惊讶的眼神:哥,你太帅了!
coolslob + 3 楼主威武—我就想问问挖掘机技术哪家强?
AIRSHAPE + 1 楼主威武—我就想问问挖掘机技术哪家强?

查看全部评分

本帖被以下淘专辑推荐:

我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2015-8-5 12:12 | 显示全部楼层
本帖最后由 d_link 于 2016-5-9 23:15 编辑

安装说明:
注: 下文中 packagename 和 initname 请根据实际情况修改
  • 自动安装

    • 将下载的IPK上传至路由器, 或者直接在路由器使用 wget 下载;
    • SSH 登录到路由器, 使用 opkg install {packagename}.ipk 安装;
    • 修改配置文件后使用 /etc/init.d/{initname} start 命令启动.
    当架构不兼容时会提示 but incompatible with the architectures configured,
    此种情况一般在 ramips_24kec 架构的软件包安装时出现.
    可以通过编辑 /etc/opkg.conf 调整架构支持,
    在文件末尾添加(也可以在 LuCI 设置页面修改):
    arch all 1
    arch ralink 200
    arch ramips_24kec 100
    添加完成后使用 opkg update 更新一次
    再次使用 opkg install {packagename}.ipk 安装
  • 手动安装

    • 解压 ipk 包: tar xzf {packagename}.ipk
    • 解压 data 包完成最终安装: tar xzf data.tar.gz -C /
    • 删除安装包残留: rm {packagename}.ipk control.tar.gz data.tar.gz debian-binary
    注: 上面 3 条命令注意复制完整并替换 packagename
    手动安装后没有卸载信息, 建议只在自动安装失败时使用
    如需要卸载, 可以直接删除步骤 2 中解压出的文件

潘多拉固件的可以试试上面方法!

点评

k2 pandubox无法安装,改了文件提示libc*和另一个英文,小白不知道怎么安装依赖库,手动安装后ip变成192.168.8.1,但是没菜单  发表于 2016-11-22 11:13
HG255D挂8187L卡装插件出现错误 固件版本 OpenWrt-DreamBox 20120828【trunk+svn】 核心版本2.6.32.59 Collected errors: * satisfy_dependencies_for: Cannot satisf  详情 回复 发表于 2016-9-5 01:58
HG255D挂8187L卡装插件出现错误 固件版本 OpenWrt-DreamBox 20120828【trunk+svn】 核心版本2.6.32.59 Collected errors: * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-a   发表于 2016-9-5 01:46
7620N潘多拉可以安装,但启动后总是重启。  详情 回复 发表于 2016-7-28 11:12
能移植到UBNT里吗?  详情 回复 发表于 2016-4-14 18:40
padorabox可以手动装上,但只有界面,根本没法使用。  发表于 2015-12-2 16:08
关于需要修改无线接口的,怎么改怎么查看,有没有具体的步骤,新手求教,或者希望能改进,谢谢。  发表于 2015-11-22 08:29
解压的文件在哪里啊?  发表于 2015-11-10 11:53
潘多拉装上了,不知道怎么调试,按照插件上字面的意思,一路填写下来,也填写了几个wifi(为什么不能搜索附近的SSID然后加入,却要手动自己填写),打开路由并没有搜到插件建立的wifi,只看到潘多拉自己开机建的两个w  详情 回复 发表于 2015-10-12 10:24
弄7620的你就火了  详情 回复 发表于 2015-8-23 23:35
255D应该下载哪一个呢  详情 回复 发表于 2015-8-12 14:44
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2015-8-5 12:12 | 显示全部楼层
再占一层。。。

点评

请问解压后放入tmp目录后怎样操作执行呀?小白不会  详情 回复 发表于 2015-9-18 11:54
请问解压后放入tmp目录后怎样操作执行呀?小白不会  详情 回复 发表于 2015-9-18 11:51
能弄个7620的吗  详情 回复 发表于 2015-8-11 16:34
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-8-5 12:30 | 显示全部楼层
撸过瞅瞅热闹
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-8-5 12:57 | 显示全部楼层
抢占楼层
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-8-5 13:17 | 显示全部楼层
很强悍的样子,顶顶……
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-8-5 13:37 | 显示全部楼层
看热闹来了,非常不错的东西。

点评

xiabule,看不了,谁发个不用积分的下来用下  详情 回复 发表于 2016-8-21 13:28
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-8-5 13:44 | 显示全部楼层
神器啊。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-8-5 13:44 | 显示全部楼层
好东西,正需要!!
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-8-5 13:54 | 显示全部楼层
神器
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-8-5 15:48 | 显示全部楼层
神器啊,支持了
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-8-5 16:10 | 显示全部楼层
diaobaole
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-8-5 17:11 | 显示全部楼层
相当实用的一个软件   解决断网必须要插网线的烦恼   想问下楼主  这个适用的版本有没限制?    我的是AR 7240    openwrt版本 3.10.49

点评

我看了一下,AR7240应该也是AR71XX平台的,是能用的。  详情 回复 发表于 2015-8-5 22:11
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-8-5 18:38 | 显示全部楼层
希望全平台都支持。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-8-5 19:59 | 显示全部楼层
神啊!!!搞DDWRT的AUTOAP都快疯了都搞不定,这回可以把极1S丢一边去了,要是能支持941V5(AR7240)改UBNT 就完美了
我的恩山、我的无线 The best wifi forum is right here.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|手机APP版|恩山无线论坛 ( 苏ICP备05084872号-1 )  

GMT+8, 2017-11-24 19:12

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表