恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
当贝投影
查看: 66394|回复: 102

[推荐].新的QOS脚本.sqm-scriptes.简单易用.从此网络不再卡!

  [复制链接]
发表于 2015-2-2 08:34 | 显示全部楼层 |阅读模式
本帖最后由 masterkuo 于 2015-3-5 15:46 编辑

因之前Trunk版一直有严重BUG,所以用BB版。最近Trunk版看起来似乎稳定了,决定换回。在编译的时候,意外发现一个新增工具sqm-scriptes,试了一下挺好用,果断抛弃qos-scripts。
sqm-scriptes是从Cerowrt移植过来的工具,有Luci界面,配置简单,效果却好。
官网的wiki地址:点我
官网的设置教程:点我

2015-02-02 07:59:46 的屏幕截图.png 2015-02-02 08:00:10 的屏幕截图.png 2015-02-02 08:00:28 的屏幕截图.png


设置方法归纳起来很简单:选择要整形的网络接口(可以设置多个,一般是wan口),上行和下行速率设置为实际速率的0.85~0.95,其它保持默认就好(请自行试验,直到找到一个“效果最佳,损失最少”的值)。


*注意:
  • 上下行速率的单位是kbit/s 而非kbyte/s
  • ADSL、VDSL或MTU>1500的,还要在“Link Layer Adaptation”标签下另行配置一下。
  • 在/etc/sysctl 添加以下内容,以支持ECN。——此部分作废:实践发现不必自行设置,有需要的分别设置客户端即可。
    1. <font color="#c0c0c0"># Enable ECN
    2. #        Possible values are:
    3. #                0 disable ECN
    4. #                1 ECN enabled
    5. #                2 Only server-side ECN enabled. If the other end does
    6. #                        not support ECN, behavior is like with ECN disabled.
    7. net.ipv4.tcp_ecn=2</font>
    复制代码

若手里有直连很快的国内VPS,或其它有公网IP的计算机,可以使用netperf配合netperf-wrapper确定最佳值。(楼主真这么干了,发现费的功夫不少,意义不大,折腾帝可以尝试)

设置的理想状态,高负载,低延迟:
ipv6_withsqm-24-4400-long.png


【若用得好,大家就回复一下,可以让更多人看到】




我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-2-2 09:12 | 显示全部楼层
完全不懂。。。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-2-2 10:58 | 显示全部楼层
楼主,这个脚本在哪里可以下载到? BB里opkg update ,直接opkg install  sqm-scriptes可以安装吗??

点评

Trunk 有,BB本身没有但可以用,可以从Trunk的Repo安装或者自行编译。  详情 回复 发表于 2015-2-2 12:27
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2015-2-2 12:27 | 显示全部楼层
Jason.lee 发表于 2015-2-2 10:58
楼主,这个脚本在哪里可以下载到? BB里opkg update ,直接opkg install  sqm-scriptes可以安装吗??

Trunk 有,BB本身没有但可以用,可以从Trunk的Repo安装或者自行编译。

点评

怎么样从Trunk的Repo安装,麻烦楼主给个详细看方法吧.有劳了.  详情 回复 发表于 2015-2-2 13:11
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-2-2 12:50 来自手机 | 显示全部楼层
灵活度不够
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-2-2 13:11 | 显示全部楼层
masterkuo 发表于 2015-2-2 12:27
Trunk 有,BB本身没有但可以用,可以从Trunk的Repo安装或者自行编译。

怎么样从Trunk的Repo安装,麻烦楼主给个详细看方法吧.有劳了.

点评

Repo: src/gz chaos_calmer_packages http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/packages 也可以直接浏览器打开:http://downloads.openwrt.org/snapshots/trunk/ar71xx/generi  详情 回复 发表于 2015-2-2 13:21
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2015-2-2 13:21 | 显示全部楼层
Jason.lee 发表于 2015-2-2 13:11
怎么样从Trunk的Repo安装,麻烦楼主给个详细看方法吧.有劳了.


Repo: src/gz chaos_calmer_packages http://downloads.openwrt.org/sna ... c/packages/packages


也可以直接浏览器打开:http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/packages 搜索:sqm-scripts和luci-app-sqm,下载传到路由手动安装。

点评

安装时,提示以下错误信息,要安装哪个依赖包啊。楼主。 root@OpenWrt:/tmp# opkg install sqm-scripts_7-3_all.ipk Installing sqm-scripts (7-3) to root... Collected errors: * satisfy_dependencies_for  详情 回复 发表于 2015-2-2 21:43
收到,非常感谢。  详情 回复 发表于 2015-2-2 21:38
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-2-2 15:44 | 显示全部楼层
感觉比qos-scripts好点,至少小水管一边网盘满速上传一边开网页不卡了

点评

如此给力啊  发表于 2015-3-18 15:32
我的恩山、我的无线 The best wifi forum is right here.
头像被屏蔽
发表于 2015-2-2 15:45 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-2-2 18:17 | 显示全部楼层
谢谢推荐,试一下好不好用。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-2-2 19:00 | 显示全部楼层
本帖最后由 quine 于 2015-2-2 22:02 编辑

谢谢分享,不过 wndr4300 bb 14.07 安装过程中有出错提示,不知道使用起来会有啥问题不


root@OpenWrt:~# opkg install ./sqm-scripts_7-3_all.ipk
Installing sqm-scripts (7-3) to root...
Configuring sqm-scripts.
//usr/lib/opkg/info/sqm-scripts.postinst: line 4: default_postinst: not found
Collected errors:
* pkg_run_script: package "sqm-scripts" postinst script returned status 127.
* opkg_configure: sqm-scripts.postinst returned 127.

root@OpenWrt:~# opkg install ./luci-app-sqm_3-1_all.ipk
Installing luci-app-sqm (3-1) to root...
Configuring sqm-scripts.
//usr/lib/opkg/info/sqm-scripts.postinst: line 4: default_postinst: not found
Configuring luci-app-sqm.
//usr/lib/opkg/info/luci-app-sqm.postinst: line 4: default_postinst: not found
Collected errors:
* pkg_run_script: package "sqm-scripts" postinst script returned status 127.
* opkg_configure: sqm-scripts.postinst returned 127.
* pkg_run_script: package "luci-app-sqm" postinst script returned status 127.
* opkg_configure: luci-app-sqm.postinst returned 127.



点评

解决了,方法如下: 临时解决办法(注意这个是一条命令): echo -e "\ndefault_postinst() {\n\ \treturn 0\n\ }\n\ default_prerm() {\n\ \treturn 0\n\ }" >> /lib/functions.sh 运行后再尝试安装  详情 回复 发表于 2015-2-2 22:12
和你一样遇到同样的问题,你要是解决了分享一下啊。  详情 回复 发表于 2015-2-2 22:08
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-2-2 21:38 | 显示全部楼层
masterkuo 发表于 2015-2-2 13:21
Repo: src/gz chaos_calmer_packages http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/p ...

收到,非常感谢。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-2-2 21:43 | 显示全部楼层
masterkuo 发表于 2015-2-2 13:21
Repo: src/gz chaos_calmer_packages http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/p ...

安装时,提示以下错误信息,要安装哪个依赖包啊。楼主。

root@OpenWrt:/tmp# opkg install sqm-scripts_7-3_all.ipk
Installing sqm-scripts (7-3) to root...
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for sqm-scripts:
*      tc *    kmod-sched *    kmod-ifb *      ip *    iptables-mod-filter *  iptables-mod-ipopt *     iptables-mod-conntrack-extra *
* opkg_install_cmd: Cannot install package sqm-scripts.
root@OpenWrt:/tmp#
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2015-2-2 21:47 | 显示全部楼层
Jason.lee 发表于 2015-2-2 21:43
安装时,提示以下错误信息,要安装哪个依赖包啊。楼主。

root@OpenWrt:/tmp# opkg install sqm-script ...
* satisfy_dependencies_for: Cannot satisfy the following dependencies for sqm-scripts:
*      tc *    kmod-sched *    kmod-ifb *      ip *    iptables-mod-filter *  iptables-mod-ipopt *     iptables-mod-conntrack-extra *

点评

依赖包装好了,可以安装过程又出现问题了。楼主帮帮忙啊。 root@OpenWrt:/tmp# opkg install sqm-scripts_7-3_all.ipk Installing sqm-scripts (7-3) to root... Configuring sqm-scripts. //usr/lib/opkg/inf  详情 回复 发表于 2015-2-2 21:58
下面这两个,在findpackage里搜的话,出来一大堆,不知道是哪个包。请楼主指点一下。谢谢。 tc * ip * 下面这些可以在findpackage搜出来。 kmod-sched * kmod-ifb * iptables-mod-filter *  详情 回复 发表于 2015-2-2 21:50
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-2-2 21:50 | 显示全部楼层

下面这两个,在findpackage里搜的话,出来一大堆,不知道是哪个包。请楼主指点一下。谢谢。
tc *   
ip *

下面这些可以在findpackage搜出来。
kmod-sched *    kmod-ifb *        iptables-mod-filter *  iptables-mod-ipopt *     iptables-mod-conntrack-extra
我的恩山、我的无线 The best wifi forum is right here.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|恩山无线论坛(常州市恩山计算机开发有限公司版权所有) ( 苏ICP备05084872号 )|网站地图

GMT+8, 2022-5-19 20:38

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表