恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 408|回复: 13

openwrt 的luci界面显示https不安全

[复制链接]
发表于 2019-12-3 11:23 | 显示全部楼层 |阅读模式
网上说设置uhttpd这个,我小白一个,说要更新证书,怎么弄。怎么才可以在编译固件的时候把这个不安全去掉。剩的以后都要在线更改
1575343254(1).jpg
我的恩山、我的无线 The best wifi forum is right here.
发表于 2019-12-3 11:44 | 显示全部楼层
luci-app-uhttpd上面有相关选项,但具体你要自己试了。
114436zjrm3sefe5r3er25.jpg
来自苹果客户端来自苹果客户端
我的恩山、我的无线 The best wifi forum is right here.
发表于 2019-12-3 11:46 | 显示全部楼层
如果只是不想出现这个不安全,编译的时候去掉luci-ssl,那么它就不会以https来访问,也就不会出现不安全。

点评

那我删掉之后,就不能用电脑网页打开luci界面了吧。还有我安装了luci-app-uhttpd。我一点那个删除旧证书整个页面就没掉了  详情 回复 发表于 2019-12-3 12:38
来自苹果客户端来自苹果客户端
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2019-12-3 12:38 | 显示全部楼层
青烟 发表于 2019-12-3 11:46
如果只是不想出现这个不安全,编译的时候去掉luci-ssl,那么它就不会以https来访问,也就不会出现不安全。
...

那我删掉之后,就不能用电脑网页打开luci界面了吧。还有我安装了luci-app-uhttpd。我一点那个删除旧证书整个页面就没掉了
K]_8L${XXU9WIDOR[(}9E_4.png
5R`U[HSN5KSK7J)ZCIPXJPJ.png
我的恩山、我的无线 The best wifi forum is right here.
发表于 2019-12-3 13:33 | 显示全部楼层
陈Eighteen 发表于 2019-12-3 12:38
那我删掉之后,就不能用电脑网页打开luci界面了吧。还有我安装了luci-app-uhttpd。我一点那个删除旧证书 ...

那可能你没安装默认的luci,ssh进去安装下就可以了:opkg install luci

点评

编译的时候去掉luci-ssl,重新编译了一次,还是会出现不安全  详情 回复 发表于 2019-12-3 16:17
那我删掉试试吧。我默认编译的固件是有luci的  详情 回复 发表于 2019-12-3 14:11
来自苹果客户端来自苹果客户端
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2019-12-3 14:11 | 显示全部楼层
青烟 发表于 2019-12-3 13:33
那可能你没安装默认的luci,ssh进去安装下就可以了:opkg install luci

那我删掉试试吧。我默认编译的固件是有luci的
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2019-12-3 16:17 | 显示全部楼层
青烟 发表于 2019-12-3 13:33
那可能你没安装默认的luci,ssh进去安装下就可以了:opkg install luci

编译的时候去掉luci-ssl,重新编译了一次,还是会出现不安全
我的恩山、我的无线 The best wifi forum is right here.
发表于 2019-12-3 16:22 | 显示全部楼层
改uhttp的配置 把自动跳转https的去掉 再清除浏览器缓存
来自安卓客户端来自安卓客户端
我的恩山、我的无线 The best wifi forum is right here.
发表于 2019-12-3 18:08 | 显示全部楼层
陈Eighteen 发表于 2019-12-3 16:17
编译的时候去掉luci-ssl,重新编译了一次,还是会出现不安全

网址开头是不是http?显示不安全但不是红色的吧?

点评

是红色的还  详情 回复 发表于 2019-12-4 09:53
来自苹果客户端来自苹果客户端
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2019-12-4 09:53 | 显示全部楼层
青烟 发表于 2019-12-3 18:08
网址开头是不是http?显示不安全但不是红色的吧?

是红色的还
7MDU7%QWS%R~BFEY{)(ZKLR.png
我的恩山、我的无线 The best wifi forum is right here.
发表于 2019-12-4 09:58 | 显示全部楼层
陈Eighteen 发表于 2019-12-4 09:53
是红色的还

跳转到https了,可能是你在uhttpd里面设置了强制https,使用http就不会。

点评

好的我试试等会谢谢  详情 回复 发表于 2019-12-4 10:26
来自苹果客户端来自苹果客户端
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2019-12-4 10:26 | 显示全部楼层
青烟 发表于 2019-12-4 09:58
跳转到https了,可能是你在uhttpd里面设置了强制https,使用http就不会。

好的我试试等会谢谢
我的恩山、我的无线 The best wifi forum is right here.
发表于 2019-12-4 11:04 | 显示全部楼层
本帖最后由 wulishui 于 2019-12-4 11:13 编辑

看你这么辛苦,还是帮帮你吧。
这是因为你集成了某些app,这些app强迫修改uhttp的配置重定向https,已知有baiduweb,kodex、、、、、、等等,关闭重定向就好。

11楼是对的,可是他没有告诉你办法。

一条命令的事。

uci set uhttpd.main.redirect_https='0'
uci commit uhttpd

上面两行可以放到lean的zzz-default-settings 里面,也可以在终端输入

或者直接在uhttp配置里面修改好再编译。(zzz-default-settings有最终决定权,前面怎么改,它都是最后决定,建议改zzz-default-settings)

自从认认真真回答一个沙鼻的问题被人横眉冷视、却和一个无厘头打屁、四处招惹是非的搭得火热之后,我就再也不想搭理此类问题。

这类自定义修改还有好多

抓取1.gif

点评

好的我现在已经 弄好了。我关闭掉了重定向还有luci-ssh。谢谢各位大哥辛勤讲解  详情 回复 发表于 2019-12-4 13:28
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2019-12-4 13:28 | 显示全部楼层
wulishui 发表于 2019-12-4 11:04
看你这么辛苦,还是帮帮你吧。
这是因为你集成了某些app,这些app强迫修改uhttp的配置重定向https,已知有 ...

好的我现在已经 弄好了。我关闭掉了重定向还有luci-ssh。谢谢各位大哥辛勤讲解
我的恩山、我的无线 The best wifi forum is right here.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|恩山无线论坛(常州市恩山计算机开发有限公司版权所有) ( 苏ICP备05084872号 )

GMT+8, 2019-12-12 15:10

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表