恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 9289|回复: 29

记 TP-LINK WDR3320 v2 LEDE固件 2.4G不能开启的解决方案

  [复制链接]
发表于 2017-10-13 21:12 | 显示全部楼层 |阅读模式
本帖最后由 libc0607 于 2017-10-14 11:20 编辑

很久之前搞了台 TP-LINK WDR3320 v2,原厂 Flash 中提取的 ART,刷啥固件都没 2.4G 。今天突然想起,翻出来,搜了下发现好像是可以解决的。。  参考 https://bugs.lede-project.org/index.php?do=details&task_id=697,大概意思应该是 ART 里面有一个字节叫 eepMisc,它的有一位是用来指示数据的大小端的。。  
然后我的机器原厂带的 ART 貌似把这一位写错了(。
解决方案也很简单,如果你的这个机器的 ART 的 0x5107 字节是 00 的话,改成01;然后把 0x5102, 0x5103 两位填充为 ffff,保存,刷到机器里,启动
然后在内核日志里找像是 'Bad EEPROM checksum' 这样的,记下后面写的 checksum,填到 ART 的 0x5102, 0x5103 两位上,保存,再刷,再重启,无线就能用了
没图,忘了截图了(


搜了一下貌似也有一部分人有这个问题但也有人没有。。(?),怀疑是原厂有一批出错了。。如果有类似情况的可以看下是否有什么共同点
QQ截图20171014111915.png

我的恩山、我的无线 The best wifi forum is right here.
发表于 2017-10-13 22:10 | 显示全部楼层
好像刷lede op这种问题还是比较多的  我dir645 也遇到过 束手无策 2.4 mac地址也正常 又是原厂uboot  没有breed  没办法折腾  下次试试你的方法

点评

用 编译出来的固件能启动 2.4G 和 5G,:victory 2.4G 和 5G 的灯都亮了 :  详情 回复 发表于 2017-10-13 22:49
我的恩山、我的无线 The best wifi forum is right here.
发表于 2017-10-13 22:42 | 显示全部楼层
compat-wireless-2016-01-10.tar.bz2
编译出来的固件能启动 2.4G 和 5G,

2.4G 和 5G 的灯都亮了



我的恩山、我的无线 The best wifi forum is right here.
发表于 2017-10-13 22:49 | 显示全部楼层
zhl416 发表于 2017-10-13 22:10
好像刷lede op这种问题还是比较多的  我dir645 也遇到过 束手无策 2.4 mac地址也正常 又是原厂uboot  没有b ...

compat-wireless-2016-01-10.tar.bz2


编译出来的固件能启动 2.4G 和 5G,:victory

2.4G 和 5G 的灯都亮了 :
我的恩山、我的无线 The best wifi forum is right here.
发表于 2017-11-15 09:31 来自手机 | 显示全部楼层
楼主用什么软件改的
我的恩山、我的无线 The best wifi forum is right here.
发表于 2017-11-15 09:37 来自手机 | 显示全部楼层
没有找到0x5102,0x5103,xx5107

点评

是地址啊。。。  详情 回复 发表于 2017-12-24 21:39
我的恩山、我的无线 The best wifi forum is right here.
发表于 2017-12-14 13:58 | 显示全部楼层
大佬可以指导我一下吗 本人小白 不会搞了

点评

过程写得很清楚了。。哪步有问题贴上来大家看看  详情 回复 发表于 2017-12-24 21:40
我的恩山、我的无线 The best wifi forum is right here.
发表于 2017-12-23 20:33 | 显示全部楼层
有是有信息好弱
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2017-12-24 21:39 | 显示全部楼层
zengxiaopingz 发表于 2017-11-15 09:37
没有找到0x5102,0x5103,xx5107

是地址啊。。。
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2017-12-24 21:40 | 显示全部楼层
qiaosky110 发表于 2017-12-14 13:58
大佬可以指导我一下吗 本人小白 不会搞了

过程写得很清楚了。。哪步有问题贴上来大家看看
我的恩山、我的无线 The best wifi forum is right here.
发表于 2017-12-26 11:44 | 显示全部楼层
我也没看懂,没基础。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2018-1-2 14:16 | 显示全部楼层
本帖最后由 vx1 于 2018-1-5 14:21 编辑

刷最新LEDE 开发版,WDR3320还是没2.4G! 5G有!
我的恩山、我的无线 The best wifi forum is right here.
发表于 2018-2-23 22:43 | 显示全部楼层
楼主的方法有效,讲一下我的步骤
1,先按住路由器复位键,插拔电源,等灯闪3下松开,进入breed,固件备份里面备份出art文件
2,下载winhex打开刚才备份的art文件,可以看到左边有地址栏,拉到 捕获.JPG
我的恩山、我的无线 The best wifi forum is right here.
发表于 2018-2-23 22:50 | 显示全部楼层
00005100那里,可以看到列上面有0 1 2 3 4 5 6 7就是对应的5102 5103 5107地址(上图中变色那些前面2个,最后面1个)
修改后, 捕获.JPG
3.进入breed上传修改好的文件,重启进入openwrt,查看内核日志里面的Bad EEPROM checksum后面的信息,我这里显示的是0x1b9a
4.所以如上图我填进去刚才那个winhex里面那里,重新保存一份art文件,再进入breed上传,重启路由后2.4g就正常了

点评

你用的那个版本的OP,我的刷了日志里面怎么不出现Bad EEPROM checksum???  详情 回复 发表于 2018-3-4 21:10
66666 怀疑是出厂的时候他们就写错了art  详情 回复 发表于 2018-2-28 15:34
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2018-2-28 15:34 | 显示全部楼层
xfdu88 发表于 2018-2-23 22:50
00005100那里,可以看到列上面有0 1 2 3 4 5 6 7就是对应的5102 5103 5107地址(上图中变色那些前面2个,最 ...

66666
怀疑是出厂的时候他们就写错了art

点评

用低版本的源代码编译就好,你看看我的灯都点亮了, 勿请胡乱灌水  详情 回复 发表于 2018-3-7 14:19
我的恩山、我的无线 The best wifi forum is right here.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|恩山无线论坛(常州市恩山计算机开发有限公司版权所有) ( 苏ICP备05084872号 )

GMT+8, 2019-12-11 09:30

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表