恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 1679|回复: 12

openwrt插上usb网卡后,无法分配ip

[复制链接]
发表于 2020-2-29 10:09 | 显示全部楼层 |阅读模式
各位,我是新路由3.刷上了openwrt之后,挂载了3070芯片的usb网卡。编译wifi固件后已经能够识别usb网卡了
无标题.png
但是连上这个wifi后,无法分配到ip
无标题.png
网络配置如下
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdbb:e265:8ae1::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '20:76:93:51:81:fd'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

我的恩山、我的无线 The best wifi forum is right here.
发表于 2020-2-29 13:46 | 显示全部楼层
问一下怎么挂3070无线网卡啊

点评

我把我编译好的有网卡驱动的固件发给你吧 链接:https://pan.baidu.com/s/1ZIW4bGvFpUlaSSTSO6FejA 提取码:2mga  详情 回复 发表于 2020-3-4 17:17
我挂载成功了,但是网速感人,150兆的usb无线网卡只能跑到1兆。。。。。  详情 回复 发表于 2020-3-3 21:52
来自安卓客户端来自安卓客户端
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-3-3 21:52 | 显示全部楼层
祝宏志 发表于 2020-2-29 13:46
问一下怎么挂3070无线网卡啊

我挂载成功了,但是网速感人,150兆的usb无线网卡只能跑到1兆。。。。。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2020-3-4 07:16 | 显示全部楼层
qipaqiu 发表于 2020-3-3 21:52
我挂载成功了,但是网速感人,150兆的usb无线网卡只能跑到1兆。。。。。

距离近的WIFI也是吗?
来自安卓客户端来自安卓客户端
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-3-4 17:17 | 显示全部楼层
祝宏志 发表于 2020-2-29 13:46
问一下怎么挂3070无线网卡啊

我把我编译好的有网卡驱动的固件发给你吧

链接:https://pan.baidu.com/s/1ZIW4bGvFpUlaSSTSO6FejA
提取码:2mga
我的恩山、我的无线 The best wifi forum is right here.
发表于 2020-3-4 19:27 | 显示全部楼层
qipaqiu 发表于 2020-3-4 17:17
我把我编译好的有网卡驱动的固件发给你吧

链接:https://pan.baidu.com/s/1ZIW4bGvFpUlaSSTSO6FejA

没有新3了,让我出了,不过还是谢谢,先收藏了,能问一下,怎么自己编译啊,都需要什么硬件啊,看你们动不动就这个自编译一个固件,那个自编译一个,我也想玩玩

点评

开源的目的之一就可以自己DIY,可以只要自己需要的东西  详情 回复 发表于 2020-3-4 19:48
来自安卓客户端来自安卓客户端
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-3-4 19:48 | 显示全部楼层
祝宏志 发表于 2020-3-4 19:27
没有新3了,让我出了,不过还是谢谢,先收藏了,能问一下,怎么自己编译啊,都需要什么硬件啊,看你们动 ...

开源的目的之一就可以自己DIY,可以只要自己需要的东西
我的恩山、我的无线 The best wifi forum is right here.
发表于 2020-3-4 20:03 | 显示全部楼层
qipaqiu 发表于 2020-3-4 19:48
开源的目的之一就可以自己DIY,可以只要自己需要的东西

是啊,问题是我要怎么去编译,都需要什么硬件

点评

很简单呀,你可以看这个链接 https://www.youtube.com/watch?v=xyhCPXItzbQ  详情 回复 发表于 2020-3-4 20:09
来自安卓客户端来自安卓客户端
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-3-4 20:09 | 显示全部楼层
祝宏志 发表于 2020-3-4 20:03
是啊,问题是我要怎么去编译,都需要什么硬件

很简单呀,你可以看这个链接
https://www.youtube.com/watch?v=xyhCPXItzbQ
我的恩山、我的无线 The best wifi forum is right here.
发表于 2020-3-4 20:52 | 显示全部楼层
qipaqiu 发表于 2020-3-4 20:09
很简单呀,你可以看这个链接
https://www.youtube.com/watch?v=xyhCPXItzbQ

为什么打不开

点评

因为是油管视频 需要低调上网。。。。  详情 回复 发表于 2020-3-4 22:59
来自安卓客户端来自安卓客户端
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-3-4 22:59 | 显示全部楼层

因为是油管视频 需要低调上网。。。。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2020-3-4 23:39 | 显示全部楼层
qipaqiu 发表于 2020-3-4 22:59
因为是油管视频 需要低调上网。。。。

这我就跪了,国内的没有吗?

点评

国内 是随便搜一下不就有了吗。。。。自己搜新路由3 编译。就算不能谷歌,百度不是也可以吗  详情 回复 发表于 2020-3-6 22:51
来自安卓客户端来自安卓客户端
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-3-6 22:51 | 显示全部楼层
祝宏志 发表于 2020-3-4 23:39
这我就跪了,国内的没有吗?

国内 是随便搜一下不就有了吗。。。。自己搜新路由3 编译。就算不能谷歌,百度不是也可以吗
我的恩山、我的无线 The best wifi forum is right here.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|恩山无线论坛(常州市恩山计算机开发有限公司版权所有) ( 苏ICP备05084872号 )|网站地图

GMT+8, 2020-11-25 02:03

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表