设为首页收藏本站

恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
小博无线
查看: 716|回复: 7

Newifi 3刷Pandorabox安装软件包缺少libc【已解决】

[复制链接]
发表于 2018-10-12 13:57 | 显示全部楼层 |阅读模式
本帖最后由 xiaoleservice 于 2018-10-13 01:15 编辑

已经刷好了2017.08.04的Pandorabox固件,但安装软件包基本都会出错:
Collected errors: * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-adbyby:*         libc *  
* opkg_install_cmd: Cannot install package luci-app-adbyby.

在网上下载了libc的ipk,可能不匹配导致安装后无法再正常启动路由器,管理页面bad way。



求助该怎么解决?哪里有可用的libc?


另外是否可能软件源设置问题,目前还有哪些可用的软件源?


更新:问题已解决,OPKG配置出了点问题,很低级的错误,恢复出厂设置或者编辑修改OPKG配置就OK了
我的恩山、我的无线 The best wifi forum is right here.
发表于 2018-10-12 15:26 来自手机 | 显示全部楼层
pandorabox 和 openwrt 用的 libc 不一样,可执行文件是不兼容的

点评

可是要去哪儿找呢 找了好久没找到 只能找到24kec的找不到100你kc的  详情 回复 发表于 2018-10-12 16:44
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2018-10-12 16:44 | 显示全部楼层
本帖最后由 xiaoleservice 于 2018-10-12 16:51 编辑
LGA1150 发表于 2018-10-12 15:26
pandorabox 和 openwrt 用的 libc 不一样,可执行文件是不兼容的

可是要去哪儿找呢 找了好久没找到 只能找到24kec的找不到1004kc的

点评

1、1004kc 兼容 24kec 2、还是要确认是否是同一个 libc  详情 回复 发表于 2018-10-12 16:48
我的恩山、我的无线 The best wifi forum is right here.
发表于 2018-10-12 16:48 来自手机 | 显示全部楼层
xiaoleservice 发表于 2018-10-12 16:44
可是要去哪儿找呢 找了好久没找到 只能找到24kec的找不到100你kc的

1、1004kc 兼容 24kec
2、还是要确认是否是同一个 libc

点评

libc_0.9.33.2-1_ramips_24kec.ipk 用的这个,安装完直接路由器后台无法打开,网页BAD WAY,重启路由器无法再正常启动。 暂时先等看看有没有别人有确认能用的,我先刷lean的openwrt  详情 回复 发表于 2018-10-12 16:53
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2018-10-12 16:53 | 显示全部楼层
LGA1150 发表于 2018-10-12 16:48
1、1004kc 兼容 24kec
2、还是要确认是否是同一个 libc

libc_0.9.33.2-1_ramips_24kec.ipk 用的这个,安装完直接路由器后台无法打开,网页BAD WAY,重启路由器无法再正常启动。

暂时先等看看有没有别人有确认能用的,我先刷lean的openwrt
谢谢啦

点评

……你强行用别的 libc 替换会导致现有的依赖原来的 libc 的程序无法运行  详情 回复 发表于 2018-10-12 22:28
我的恩山、我的无线 The best wifi forum is right here.
发表于 2018-10-12 22:28 | 显示全部楼层
xiaoleservice 发表于 2018-10-12 16:53
libc_0.9.33.2-1_ramips_24kec.ipk 用的这个,安装完直接路由器后台无法打开,网页BAD WAY,重启路由器无 ...

……你强行用别的 libc 替换原来的 libc,会导致现有的依赖原来的 libc 的程序无法运行

点评

已经解决问题了,OPKG配置问题导致libc其实已经有了但是列表不显示,重新装又会导致之前那些依赖原本libc的程序炸掉,已经修改了OPKG相关配置,现在已经恢复正常,安装软件包正常了  详情 回复 发表于 2018-10-13 01:14
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2018-10-13 01:14 | 显示全部楼层
LGA1150 发表于 2018-10-12 22:28
……你强行用别的 libc 替换原来的 libc,会导致现有的依赖原来的 libc 的程序无法运行

已经解决问题了,OPKG配置问题导致libc其实已经有了但是列表不显示,安装也显示是全新安装,没提示已经安装过,重新装又会导致之前那些依赖原本libc的程序炸掉,已经修改了OPKG相关配置,现在已经恢复正常,安装软件包正常了
我的恩山、我的无线 The best wifi forum is right here.
发表于 2018-11-15 15:10 | 显示全部楼层
老哥怎么解决的啊,求请教
我的恩山、我的无线 The best wifi forum is right here.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|恩山无线论坛 ( 苏ICP备05084872号-1 )  

GMT+8, 2018-12-16 17:05

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表