恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 1075|回复: 10

esxi7 开机出现“未处理的异常”错误,怎么办?

[复制链接]
发表于 2020-8-8 14:10 | 显示全部楼层 |阅读模式
虚拟了3个系统:openwrt、win10、qunhui(黑群晖),都设置成开机启动,除了openwrt能正常启动外,其余2个都不能启动。而且还跳出一大堆错误提示,网上的资料很少,小白摸不着边。
1.png
复制下来的提示:
原因: Possibly unhandled rejection: {}
版本: 1.34.0
内部版本: 15603211
ESXi: 7.0.0
浏览器: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36

异常堆栈:

TypeError: Cannot read property 'slice' of undefined
    at https://192.168.123.88/ui/scripts/main.js:409:14315
    at https://192.168.123.88/ui/scripts/main.js:326:23176
    at m.$digest (https://192.168.123.88/ui/scripts/main.js:326:28780)
    at https://192.168.123.88/ui/scripts/main.js:326:30503
    at e (https://192.168.123.88/ui/scripts/main.js:325:10071)
    at https://192.168.123.88/ui/scripts/main.js:325:11522

2.png
希望能得到大侠们的帮助,谢谢了!!!
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-8-8 14:13 | 显示全部楼层
按“ESC”键无视它是可以正常运行的,手动点击另2个系统也是可以开机的。
就是红X出现太难受了。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2020-8-8 15:19 | 显示全部楼层
是不是虚拟内存抹掉了?

点评

先谢谢兄弟了。我没有抹掉的,这方面没操作过。我250G固态,不需要节省空间。 [attachimg]406150[/attachimg] 现在开机不自启另外2个系统,就没有出现错误。有没有可能是3个虚拟系统都用了“0”这个网卡作为控制  详情 回复 发表于 2020-8-8 20:23
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-8-8 20:23 | 显示全部楼层
zszmm 发表于 2020-8-8 15:19
是不是虚拟内存抹掉了?

先谢谢兄弟了。我没有抹掉的,这方面没操作过。我250G固态,不需要节省空间。
1.png

现在开机不自启另外2个系统,就没有出现错误。有没有可能是3个虚拟系统都用了“0”这个网卡作为控制端造成的错误?

我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-8-9 11:09 | 显示全部楼层
自己顶一下。
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-8-12 19:55 | 显示全部楼层
自己再顶一下。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2020-8-12 20:55 | 显示全部楼层
不清楚,一直没碰ESXI7,6.7挺好的,追求稳定,所以一般没事我都不会去用更新的版本,之前我还用5的,后来嫌vsphere烦才转的ESXI6

点评

好,那我也试试6.7吧!  详情 回复 发表于 2020-8-13 09:50
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-8-13 09:50 | 显示全部楼层
小豪豪 发表于 2020-8-12 20:55
不清楚,一直没碰ESXI7,6.7挺好的,追求稳定,所以一般没事我都不会去用更新的版本,之前我还用5的,后来 ...

好,那我也试试6.7吧!
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-8-15 10:05 | 显示全部楼层
莫名其妙地解决了,但不知是哪一步做对了。
小结如下:
1、升级了主板的BIOS。我的CPU是i5-9500T,主板是 华硕PRIME Z390M-PLUS,原先的BIOS是2606,把它升级到2808。板载网卡是Intel I219V千兆网卡,查了下,esxi7下是可以驱动的,不需要打驱动补丁。
2、换了一张同型号的网卡。我PCIE插的是4口 HP NC365T网卡,也就是INTEL I340-T4的马甲卡,主芯片是82580。当时买了2张,每张150元(现在涨价到2、3百了)。把另一张没用过的换进去。
3、重新安装了esxi7,一步一步来,先安openwrt,然后关机再开机,没有出错;第二步安黑群,同样操作;第三步安win10。在升BIOS之前,也尝试安装过esxi6.7,同样开机有出错提示,所以又安回7版本。
4、在关机前先手动关闭黑群和win10,再关机。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2020-8-15 10:59 | 显示全部楼层
我也是esxi7,有时候莫名其妙的弹错,不光是开机时,只要是连接esxi7都可能弹错。
后来发现,如果用中文界面它就是会这样,换英文界面就稳的一批了。

点评

这个我倒没试过。以后出错了再试试看。  详情 回复 发表于 2020-8-16 09:19
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-8-16 09:19 | 显示全部楼层
caliban 发表于 2020-8-15 10:59
我也是esxi7,有时候莫名其妙的弹错,不光是开机时,只要是连接esxi7都可能弹错。
后来发现,如果用中文界 ...

这个我倒没试过。以后出错了再试试看。
我的恩山、我的无线 The best wifi forum is right here.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|恩山无线论坛(常州市恩山计算机开发有限公司版权所有) ( 苏ICP备05084872号 )|网站地图

GMT+8, 2020-10-1 10:10

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表