恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 432|回复: 2

求助:openwrt配置双WAN口,ping不通IPv6地址

[复制链接]
发表于 2020-10-6 22:29 | 显示全部楼层 |阅读模式
newifi3,刷了一个支持IPv6的固件,希望配置双WAN口,分别接IPv4和IPv6,简单拓扑如下:
wan1.jpg
我现在想在openwrt上配置一个双WAN口,对外通过静态路由分别接2条固定地址的专线
WAN口接IPv4,WAN6口接IPv6,地址配上了。IPv4通,但是IPv6,OP路由器都ping不通

root@OpenWrt:~#
root@OpenWrt:~# ping -6 240E:5A:8801:8::1
PING 240E:5A:8801:8::1 (240e:5a:8801:8::1): 56 data bytes
ping: sendto: Permission denied


network的配置如下:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option _orig_ifname 'apcli0 apclii0 eth0.1 ra0 rai0'
        option _orig_bridge 'true'
        option ifname 'eth0.1'

config device 'lan_eth0_1_dev'
        option name 'eth0.1'
        option macaddr '20:76:93:44:7d:7f'

config device 'lan_ra0_dev'
        option name 'ra0'
        option macaddr '20:76:93:44:7d:7f'

config device 'lan_rai0_dev'
        option name 'rai0'
        option macaddr '20:76:93:44:7d:7f'

config device 'lan_apcli0_dev'
        option name 'apcli0'
        option macaddr '20:76:93:44:7d:7f'

config device 'lan_apclii0_dev'
        option name 'apclii0'
        option macaddr '20:76:93:44:7d:7f'

config interface 'wan'
        option ifname 'eth0.2'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '202.102.21.164'                     
        option netmask '255.255.255.128'                    
        option gateway '202.102.21.129'                     
        option dns '218.2.135.1'                           

config device 'wan_eth0_2_dev'                              
        option name 'eth0.2'                                
        option macaddr '20:76:93:44:7d:81'                  

config interface 'wan6'                                    
        option proto 'static'                              
        option ifname 'eth0.3'                              
        option ip6gw '240e:5a:8801:8::1'                    
        option ip6addr '240e:5a:8801:8:2cbc:1b1f:59cc:94d5'
        option ip6assign


请各位大神帮忙找找原因?



 楼主| 发表于 2020-10-6 22:36 | 显示全部楼层
配置没贴完
config interface 'wan6'                                    
        option proto 'static'                              
        option ifname 'eth0.3'                              
        option ip6gw '240e:5a:8801:8::1'                    
        option ip6addr '240e:5a:8801:8:2cbc:1b1f:59cc:94d5'
        option ip6assign '64'                              
                                                           
config device 'wan_eth0_3_dev'                             
        option name 'eth0.3'                              
        option macaddr '20:76:93:44:7d:83'                 
                                                           
config switch                                             
        option name 'switch0'                              
        option reset '1'                                   
        option enable_vlan '1'                             
                                                           
config switch_vlan                                         
        option device 'switch0'                           
        option vlan '1'                                    
        option vid '1'                                    
        option ports '0 1 2 6t'                           
                                                           
config switch_vlan                                         
        option device 'switch0'                           
        option vlan '2'                                    
        option ports '4 6t'                                
        option vid '2'                                    
                                                           
config switch_vlan                                         
        option device 'switch0'                           
        option vlan '3'                                    
        option vid '3'                                    
        option ports '3 6t'  

 楼主| 发表于 2020-10-6 22:57 | 显示全部楼层
root@OpenWrt:/etc/config#
root@OpenWrt:/etc/config# ping6 240E:5A:8801:8::1
PING 240E:5A:8801:8::1 (240e:5a:8801:8::1): 56 data bytes
ping6: sendto: Permission denied
root@OpenWrt:/etc/config#
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|恩山无线论坛(常州市恩山计算机开发有限公司版权所有) ( 苏ICP备05084872号 )|网站地图

GMT+8, 2021-5-7 15:55

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表