恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 356|回复: 5

编译openwrt遇到麻烦了!

[复制链接]
发表于 2021-6-11 12:22 | 显示全部楼层 |阅读模式
本帖最后由 aepub66 于 2021-6-11 14:53 编辑

编译固件,违禁软件找到了新版,但是编译出现了意外,提示为:
截屏2021-06-11 12.18.33.png
一通百度,没有找到办法,偶尔打开uci-app-违禁软件-plus的Makefile文件,发现了端倪;之前一直使用的是uci-app-违禁软件-plus的183.10版,现在编译的是184.3版,问题就在这里:
183.10版的Makefile文件如下:
截屏2021-06-11 14.50.11.png
184.3的Makefile文件如下:
截屏2021-06-11 14.50.37.png
也就是说新版本的184.3需要违禁软件r-libev-违禁软件-***这几个文件
去哪里找这几个文件依赖呢!
我的恩山、我的无线 The best wifi forum is right here.
发表于 2021-6-11 12:46 | 显示全部楼层
opkg_install_cmd: Cannot install package luci-app  提示包没有下载
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2021-6-11 14:08 | 显示全部楼层
隐形的肩膀 发表于 2021-6-11 12:46
opkg_install_cmd: Cannot install package luci-app  提示包没有下载

安装包已经在package里面了
我的恩山、我的无线 The best wifi forum is right here.
发表于 2021-6-11 17:15 | 显示全部楼层
LEDE的源码自带依赖,LIENOL的源码把帕斯窝拉取进去后再拉取LEDE源码的package/lean/socks-red2就搞定了,官方的不知道,真正编译中
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2021-6-11 17:18 | 显示全部楼层
dan123 发表于 2021-6-11 17:15
LEDE的源码自带依赖,LIENOL的源码把帕斯窝拉取进去后再拉取LEDE源码的package/lean/socks-red2就搞定了, ...

我是拉取的 coolsnowwolf/lede的源码!
我的恩山、我的无线 The best wifi forum is right here.
发表于 2021-6-11 17:37 | 显示全部楼层
aepub66 发表于 2021-6-11 17:18
我是拉取的 coolsnowwolf/lede的源码!

这样那里会缺依赖,不需要去拉取任何东西,用 sed -i 's/^#\(.*helloworld\)/\1/' feeds.conf.default 这个命令就好了
我的恩山、我的无线 The best wifi forum is right here.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|恩山无线论坛(常州市恩山计算机开发有限公司版权所有) ( 苏ICP备05084872号 )|网站地图

GMT+8, 2021-7-24 19:29

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表