找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
广告投放联系QQ68610888
查看: 476|回复: 2

移植asterisk1.8到openwrt-23.05.0使用

[复制链接]
本帖最后由 13062678135 于 2023-11-13 22:29 编辑

openwrt-23.05.0自带的asterisk是20.x版本。自asterisk16.x版本开始,已经强制切换到pjsip。会多占用掉不到1M的空间。
我这边就把古老的asterisk1.8版本移植到了23.05.0上。
asterisk1.8源码会调用musl库里不存在的cdefs.h头文件,并且代码是基于openssl1.0.x的。需要给源码进行适配。
我这边已制作好了兼容补丁,测试在mips和aarch64平台都能正常运行使用。


由于asterisk是13.x版本开始才支持RFC3566的,所以asterisk1.8版本在对接运营商voip时会有可以外线拨出,无法外线呼入的bug。
我已制作好了backport rfc3966的补丁,使asterisk对接运营商voip后可以正常的与外线呼入呼出。



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有账号?立即注册

×
来自手机 | 显示全部楼层
6啊。。。
回复

使用道具 举报

非常厉害的,对内存空间小的用户很实用
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关闭

欢迎大家光临恩山无线论坛上一条 /1 下一条

有疑问请添加管理员QQ86788181|手机版|小黑屋|Archiver|恩山无线论坛(常州市恩山计算机开发有限公司版权所有) ( 苏ICP备05084872号 )

GMT+8, 2024-5-20 05:29

Powered by Discuz! X3.5

© 2001-2024 Discuz! Team.

| 江苏省互联网有害信息举报中心 举报信箱:js12377 | @jischina.com.cn 举报电话:025-88802724 本站不良内容举报信箱:68610888@qq.com 举报电话:0519-86695797

快速回复 返回顶部 返回列表