找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
广告投放联系QQ68610888
查看: 899|回复: 10

[openwrt(x86)] OpenWrt编译插件luci-app-adguardhome出现/home/*/lede/include/toplevel.mk:231错误

[复制链接]
发表于 2023-10-30 11:57 | 显示全部楼层 |阅读模式
本帖最后由 Gulx 于 2023-10-31 08:10 编辑

OpenWrt编译插件luci-app-adguardhome出现/home/gulx/lede/include/toplevel.mk:231错误




make: *** [/home/gulx/lede/include/toplevel.mk:231:package/gulx/small-package/luci-app-adguardhome/compile] 错误 2


微信截图_20231030115202.png

QQ图片20231030124643.png

换了个源,问题解决了,再次感谢sirpdboy大佬,分享下lede大佬的源码X86-64平台使用编译的luci-app-adguardhome给需要的人
https://github.com/sirpdboy/sirpdboy-package


luci-app-adguardhome.rar (187.65 KB, 下载次数: 56)








我的恩山、我的无线 The best wifi forum is right here.
发表于 2023-10-30 12:33 | 显示全部楼层
看下包

点评

看哪个包啊  详情 回复 发表于 2023-10-30 12:36
我的恩山、我的无线 The best wifi forum is right here.
回复

使用道具 举报

 楼主| 发表于 2023-10-30 12:36 | 显示全部楼层
本帖最后由 Gulx 于 2023-10-30 12:47 编辑

看看是不是上图那个文件,我补充进来了
我的恩山、我的无线 The best wifi forum is right here.
回复

使用道具 举报

发表于 2023-10-30 16:20 | 显示全部楼层
https://github.com/yang229/luci-app-adguardhome
我用这个库没问题,要不你试试

点评

我试试,谢谢  详情 回复 发表于 2023-10-30 17:08
我的恩山、我的无线 The best wifi forum is right here.
回复

使用道具 举报

 楼主| 发表于 2023-10-30 17:08 | 显示全部楼层
本帖最后由 Gulx 于 2023-10-30 17:21 编辑

还是报一样的错误,奇怪了,我不选择这个插件,可以编译成功,选择这个插件就报错误,你有单独安装过什么支持库吗?
我的恩山、我的无线 The best wifi forum is right here.
回复

使用道具 举报

发表于 2023-10-30 17:52 | 显示全部楼层
删掉库重新来吧,你工具链编译不完整

点评

我执行过make dirclean了,除了这个命令,其他还有要删除的吗  详情 回复 发表于 2023-10-30 18:04
我的恩山、我的无线 The best wifi forum is right here.
回复

使用道具 举报

 楼主| 发表于 2023-10-30 18:04 | 显示全部楼层
wulishui 发表于 2023-10-30 17:52
删掉库重新来吧,你工具链编译不完整

我执行过make dirclean了,除了这个命令,其他还有要删除的吗

点评

工具链那一大堆依赖都按照要求安装完了吗?  详情 回复 发表于 2023-10-30 18:07
我的恩山、我的无线 The best wifi forum is right here.
回复

使用道具 举报

发表于 2023-10-30 18:07 | 显示全部楼层
Gulx 发表于 2023-10-30 18:04
我执行过make dirclean了,除了这个命令,其他还有要删除的吗

工具链那一大堆依赖都按照要求安装完了吗?
我的恩山、我的无线 The best wifi forum is right here.
回复

使用道具 举报

 楼主| 发表于 2023-10-30 20:10 | 显示全部楼层
git pull
./scripts/feeds update -a
./scripts/feeds install -a
make download -j8

这几条命令吗,反复执行过,看到都没错误了
基本上都是按照lede大神的操作来的

点评

我说的是这堆依赖 [attachimg]652591[/attachimg]  详情 回复 发表于 2023-10-30 20:23
我的恩山、我的无线 The best wifi forum is right here.
回复

使用道具 举报

发表于 2023-10-30 20:23 | 显示全部楼层
Gulx 发表于 2023-10-30 20:10
git pull
./scripts/feeds update -a
./scripts/feeds install -a

我说的是这堆依赖
抓取1.gif

点评

这个我也装了,显示都装成功了  详情 回复 发表于 2023-10-30 21:25
我的恩山、我的无线 The best wifi forum is right here.
回复

使用道具 举报

 楼主| 发表于 2023-10-30 21:25 | 显示全部楼层
wulishui 发表于 2023-10-30 20:23
我说的是这堆依赖

这个我也装了,显示都装成功了

你用的是哪个仓库的,能推荐一下吗
我的恩山、我的无线 The best wifi forum is right here.
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关闭

欢迎大家光临恩山无线论坛上一条 /1 下一条

有疑问请添加管理员QQ86788181|手机版|小黑屋|Archiver|恩山无线论坛(常州市恩山计算机开发有限公司版权所有) ( 苏ICP备05084872号 )

GMT+8, 2024-2-27 18:10

Powered by Discuz! X3.5

© 2001-2024 Discuz! Team.

| 江苏省互联网有害信息举报中心 举报信箱:js12377 | @jischina.com.cn 举报电话:025-88802724 本站不良内容举报信箱:68610888@qq.com 举报电话:0519-86695797

快速回复 返回顶部 返回列表