恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
小博无线
查看: 13632|回复: 30

wndr4300 挂硬盘

[复制链接]
发表于 2014-11-4 13:26 | 显示全部楼层 |阅读模式
本帖最后由 jemas_cao 于 2014-11-7 11:34 编辑

新买的wndr4300 折腾了op的官方固件,+中文包。
手头有一块电脑拆下来的160G硬盘,买了硬盘盒装成移动硬盘。
试了好多教程都不能挂上,更别说共享和离线下载了。
网上帖子写的好多插件都安装不上
   有没有大佬帮帮忙啊



还有就是2.4的无线设备都连接不上去,5G的设备可以连接上去但是没法上网。
有线连接倒是可以连上路由器,但也没法连接外网
Y_L07XL)DRZ}(YPYC$O)WWG.jpg
~3~]U)1}9WQ8ZC$Q4FPL@NQ.jpg
9WH9_CME_KP8]8RH2T$9~PA.jpg
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2014-11-4 13:44 | 显示全部楼层
沙发自己站,顶起来。还望高人解答
我的恩山、我的无线 The best wifi forum is right here.
发表于 2014-11-4 15:12 | 显示全部楼层
固件版本?
硬盘什么格式的NTFS?

opkg update
opkg install kmod-usb-storage
opkg install kmod-fs-ntfs
插入后 ls /dev/sda*

点评

硬盘格式是ext4 固件版本见上图  详情 回复 发表于 2014-11-4 17:29
输入后显示上图那样的吗?我怎么在电脑上访问里边的文件 ?  详情 回复 发表于 2014-11-4 17:28
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2014-11-4 17:28 | 显示全部楼层
飃渺魔君 发表于 2014-11-4 15:12
固件版本?
硬盘什么格式的NTFS?

输入后显示上图那样的吗?我怎么在电脑上访问里边的文件
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2014-11-4 17:29 | 显示全部楼层
飃渺魔君 发表于 2014-11-4 15:12
固件版本?
硬盘什么格式的NTFS?

硬盘格式是ext4  固件版本见上图

点评

mount /dev/sda1 /mnt 然后cd /mnt就可以看到里面的文档了 如果在其他设备上(如windows)直接访问,还需要安装samba: opkg update opkg install luci-app-samba 修改/etc/config/samba 增加以下内容: 修  详情 回复 发表于 2014-11-5 09:08
我的恩山、我的无线 The best wifi forum is right here.
发表于 2014-11-4 17:57 | 显示全部楼层
能不能发一个官方固件+中文包的教程给菜鸟们啊

点评

官方固件地址i:http://downloads.openwrt.org/ 然后找到你对应路由的固件就可以了。 官方中文文档地址:http://wiki.openwrt.org/zh-cn/start 供参考。  详情 回复 发表于 2014-11-5 09:11
我的恩山、我的无线 The best wifi forum is right here.
发表于 2014-11-5 09:08 | 显示全部楼层
本帖最后由 飃渺魔君 于 2014-11-5 09:14 编辑
jemas_cao 发表于 2014-11-4 17:29
硬盘格式是ext4  固件版本见上图

mount /dev/sda1 /mnt
然后cd /mnt就可以看到里面的文档了

如果在其他设备上(如windows)直接访问,还需要安装samba:
opkg update
opkg install luci-app-samba
修改/etc/config/samba
增加以下内容:

  1. config sambashare
  2.                 option 'name'                   'share'
  3.                 option 'path'                   '/mnt'
  4.                 option 'read_only'              'no'
  5.                 option 'guest_ok'               'no'
  6.                 option 'create_mask'            '0700'
  7.                 option 'dir_mask'               '0700'
复制代码

修改/etc/samba/smb.conf.template

  1.         guest ok = no
  2. #        invalid users = root
复制代码

修改后执行命令:
/etc/init.d/samba start

然后建立samba用户,用户名需要已在/etc/passwd中存在,如root用户,
如修改samba用户root的密码使用:smbpasswd root

然后windows输入路由IP地址,如  \\192.168.1.1\
输入用户名密码后就可以访问了


至于不能上外网问题,你把/etc/config/wireless和/etc/config/network发过来看看

点评

这里就不明白了,怎么建立samba用户?其他设备访问需要建立的samba用户才可以么? 我想要不访问的时候不需要输入用户和密码,能实现吗? wireless配置 config wifi-device 'radio0' option type 'mac8021  详情 回复 发表于 2014-11-6 18:43
我的恩山、我的无线 The best wifi forum is right here.
发表于 2014-11-5 09:11 | 显示全部楼层
strapx 发表于 2014-11-4 17:57
能不能发一个官方固件+中文包的教程给菜鸟们啊

官方固件地址i:http://downloads.openwrt.org/

然后找到你对应路由的固件就可以了。

官方中文文档地址:http://wiki.openwrt.org/zh-cn/start

供参考。

点评

我http://wiki.openwrt.org/zh-cn/start打不开什么原因  详情 回复 发表于 2014-11-6 18:37
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2014-11-6 18:37 | 显示全部楼层
飃渺魔君 发表于 2014-11-5 09:11
官方固件地址i:http://downloads.openwrt.org/

然后找到你对应路由的固件就可以了。

http://wiki.openwrt.org/zh-cn/start打不开什么原因
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2014-11-6 18:43 | 显示全部楼层
本帖最后由 jemas_cao 于 2014-11-6 18:46 编辑
飃渺魔君 发表于 2014-11-5 09:08
mount /dev/sda1 /mnt
然后cd /mnt就可以看到里面的文档了
然后建立samba用户,用户名需要已在/etc/passwd中存在,如root用户,
如修改samba用户root的密码使用:smbpasswd root

然后windows输入路由IP地址,如  \\192.168.1.1\
输入用户名密码后就可以访问了

这里就不明白了,怎么建立samba用户?其他设备访问需要建立的samba用户才可以么?
我想访问的时候不需要输入用户和密码,能实现吗?

wireless配置

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ar934x_wmac'
        option disabled '0'
        option channel '3'
        option txpower '30'
        option country 'US'
        option htmode 'HT40'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option channel '161'
        option country 'US'
        option txpower '30'
        option htmode 'HT40'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key '*********'
        option ssid 'OpenWrt-5G'

config wifi-iface
        option network 'wwan'
        option ssid 'TP-LINK_B988'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid 'A8:57:4E:E7:B9:88'
        option key '*********'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option encryption 'psk2'
        option key '*********'
        option ssid 'OpenWrt-2.4G'

network配置

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd3c:27e1:0769::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option macaddr '6c:b0:ce:11:90:a0'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option macaddr '6c:b0:ce:11:90:a1'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 5'

config interface 'wwan'
        option proto 'dhcp'
还望解答。

点评

访问时候不需要密码: 修改/etc/samba/smb.conf.template guest ok = yes 然后重启samba,就可以了 另:你应该挂载成功了吧?/mnt里面可以读到内容了吗?  详情 回复 发表于 2014-11-6 23:16
我的恩山、我的无线 The best wifi forum is right here.
发表于 2014-11-6 18:45 | 显示全部楼层
LZ建议你换个U盘接上去试试,看看认不认得出来,我怀疑是USB供电不够导致硬盘不识别

点评

我是外接电源的硬盘,另外我量了一下路由器的USB是5V的  详情 回复 发表于 2014-11-6 18:49
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2014-11-6 18:49 | 显示全部楼层
fonlan 发表于 2014-11-6 18:45
LZ建议你换个U盘接上去试试,看看认不认得出来,我怀疑是USB供电不够导致硬盘不识别

我是外接电源的硬盘,另外我量了一下路由器的USB是5V的

点评

哦,外接电源那应该没事,不过你量电压那是没用的,空载电压基本都是标准的5v,一接设备电压就降下来了,电流也不一定够  详情 回复 发表于 2014-11-6 18:51
我的恩山、我的无线 The best wifi forum is right here.
发表于 2014-11-6 18:51 | 显示全部楼层
jemas_cao 发表于 2014-11-6 18:49
我是外接电源的硬盘,另外我量了一下路由器的USB是5V的

哦,外接电源那应该没事,不过你量电压那是没用的,空载电压基本都是标准的5v,一接设备电压就降下来了,电流也不一定够

点评

路由器的电源是12V2A的 不知道外挂大功率网卡够不够用  详情 回复 发表于 2014-11-6 18:53
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2014-11-6 18:53 | 显示全部楼层
fonlan 发表于 2014-11-6 18:51
哦,外接电源那应该没事,不过你量电压那是没用的,空载电压基本都是标准的5v,一接设备电压就降下来了, ...

路由器的电源是12V2A的 不知道外挂大功率网卡够不够用
我的恩山、我的无线 The best wifi forum is right here.
发表于 2014-11-6 23:16 | 显示全部楼层
jemas_cao 发表于 2014-11-6 18:43
这里就不明白了,怎么建立samba用户?其他设备访问需要建立的samba用户才可以么?
我想访问的时候不需 ...

访问时候不需要密码:
修改/etc/samba/smb.conf.template
guest ok = yes

然后重启samba,就可以了
另:你应该挂载成功了吧?/mnt里面可以读到内容了吗?

点评

大哥 救救我啊 才买的这个路由器,也才接触op 啊,一头雾水啊!!硬盘死活挂不上啊!大哥 帮忙下,谢谢!!!QQ 1418607497 手机 18608286299 谢谢!!!  详情 回复 发表于 2015-3-2 23:29
按照你说的秀海后还是需要用户和密码,问题是我不知道怎么建立用户 我的smbpassword文件中是空白的  详情 回复 发表于 2014-11-7 11:39
选择的挂载点不在已挂载的设备里边,看上图  详情 回复 发表于 2014-11-7 11:33
没有哦,搞不定。不知道可不可以帮我远程搞一下,企鹅903417129  详情 回复 发表于 2014-11-7 10:52
我的恩山、我的无线 The best wifi forum is right here.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|恩山无线论坛 ( 苏ICP备05084872号-1 )

GMT+8, 2019-1-20 23:06

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表