恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 145|回复: 7

依赖包出错 请问如何解决

[复制链接]
发表于 2021-9-15 17:42 | 显示全部楼层 |阅读模式
10恩山币
WARNING: Makefile 'package/lean/luci-app-wrtbwmon/Makefile' has a dependency on 'wrtbwmon', which does not exist


我的恩山、我的无线 The best wifi forum is right here.
发表于 2021-9-15 18:43 | 显示全部楼层
删除.config文件重新配置试试。有时候重复修改配置文件也会这样。

点评

在进menuconfig之前就提示报错了。在./scripts/feeds install -a 之后  详情 回复 发表于 2021-9-15 19:08
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2021-9-15 19:08 | 显示全部楼层
onllno 发表于 2021-9-15 18:43
删除.config文件重新配置试试。有时候重复修改配置文件也会这样。

在进menuconfig之前就提示报错了。在./scripts/feeds install -a 之后
我的恩山、我的无线 The best wifi forum is right here.
发表于 2021-9-15 20:24 | 显示全部楼层
sudo git install wrtbwmon
试试

点评

提示没有这个命令  详情 回复 发表于 2021-9-15 20:57
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2021-9-15 20:57 | 显示全部楼层
onllno 发表于 2021-9-15 20:24
sudo git install wrtbwmon
试试

提示没有这个命令

点评

你用的什么系统?安装依赖包的命令正常执行完成了吗?是不是有部份没有安装成功?  详情 回复 发表于 2021-9-15 22:33
我的恩山、我的无线 The best wifi forum is right here.
发表于 2021-9-15 21:56 | 显示全部楼层
截图未命名.jpg

用我给你的软件库来编辑吧,我编译成功了
我的恩山、我的无线 The best wifi forum is right here.
发表于 2021-9-15 22:33 | 显示全部楼层
jk2008chd 发表于 2021-9-15 20:57
提示没有这个命令

你用的什么系统?安装依赖包的命令正常执行完成了吗?是不是有部份没有安装成功?

点评

ubuntu 虚拟机。 拉取的lede源码 和Sirpdboy的仓库。 可能是wrtbwmon 重复冲突之类的吧。基础依赖包是wrtbwmon。另外还有个luci-wrtbwmon的插件包。现在已经解决 单独运行一下 ./scripts/feeds install wrtbwmon 再  详情 回复 发表于 2021-9-16 00:39
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2021-9-16 00:39 | 显示全部楼层
onllno 发表于 2021-9-15 22:33
你用的什么系统?安装依赖包的命令正常执行完成了吗?是不是有部份没有安装成功?

ubuntu 虚拟机。 拉取的lede源码 和Sirpdboy的仓库。 可能是wrtbwmon 重复冲突之类的吧。基础依赖包是wrtbwmon。另外还有个luci-wrtbwmon的插件包。现在已经解决 单独运行一下 ./scripts/feeds install wrtbwmon 再进menuconfig就正常了
我的恩山、我的无线 The best wifi forum is right here.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|恩山无线论坛(常州市恩山计算机开发有限公司版权所有) ( 苏ICP备05084872号 )|网站地图

GMT+8, 2021-9-19 18:58

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表