恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
当贝投影
查看: 867|回复: 19

[Router OS] ROS和op双软路由DNS设置问题

[复制链接]
发表于 2022-4-25 00:04 | 显示全部楼层 |阅读模式
用esxi装了Ros+OP,由于ros的dns指向了op(比如192.168.0.1),当op关机后,所有网络就会断掉,上不了网。因为ros找不到dns.
如何通过netwatch监控op,当ros发现op(比如192.168.0.1)不在线时,将dns自动切换为114.114.114.114?脚本如何实现?请大神指点。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2022-4-25 00:23 | 显示全部楼层
1.3为OP
up
/ip dns set servers=192.168.1.3
/ip dns cache flush
down
/ip dns set servers=202.106.46.151,202.106.195.68
/ip dns cache flush

Host
host:OP的ip
间隔:1分钟
延迟100ms
不用谢

点评

求解gateway,在netwatch如何设置?  详情 回复 发表于 2022-4-26 16:14
大神,有没有图文教程  详情 回复 发表于 2022-4-25 10:19
感谢大神,厉害  详情 回复 发表于 2022-4-25 08:32
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2022-4-25 08:32 | 显示全部楼层
375860933 发表于 2022-4-25 00:23
1.3为OP
up
/ip dns set servers=192.168.1.3

感谢大神,厉害
我的恩山、我的无线 The best wifi forum is right here.
发表于 2022-4-25 08:34 | 显示全部楼层
ROS正常使用普通DNS解析不需要外网的设备  把需要外网的设配分配指定OP的网关和DNS就好了

https://www.openos.org/threads/routeros-dhcp-dns.3515/

点评

需要全局,这种一个一个指定的会很麻烦。谢谢大神  详情 回复 发表于 2022-4-25 08:55
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2022-4-25 08:55 | 显示全部楼层
造假派五号 发表于 2022-4-25 08:34
ROS正常使用普通DNS解析不需要外网的设备  把需要外网的设配分配指定OP的网关和DNS就好了

https://www.o ...

需要全局,这种一个一个指定的会很麻烦。谢谢大神
我的恩山、我的无线 The best wifi forum is right here.
发表于 2022-4-25 10:19 | 显示全部楼层
375860933 发表于 2022-4-25 00:23
1.3为OP
up
/ip dns set servers=192.168.1.3

大神,有没有图文教程

点评

[attachimg]548394[/attachimg][attachimg]548395[/attachimg][attachimg]548396[/attachimg]  详情 回复 发表于 2022-4-25 18:58
我的恩山、我的无线 The best wifi forum is right here.
发表于 2022-4-25 10:44 | 显示全部楼层
你把114设为备用dns
我的恩山、我的无线 The best wifi forum is right here.
发表于 2022-4-25 18:58 | 显示全部楼层
Masterchen666 发表于 2022-4-25 10:19
大神,有没有图文教程

1.jpg 2.jpg 3.jpg

点评

你好,请问dns set servers=202.106.46.151,202.106.195.68。这里的dns可以设置成公共dns吗?  详情 回复 发表于 2022-4-25 19:31
我的恩山、我的无线 The best wifi forum is right here.
发表于 2022-4-25 19:31 | 显示全部楼层

你好,请问dns set servers=202.106.46.151,202.106.195.68。这里的dns可以设置成公共dns吗?

点评

202.106.46.151,202.106.195.68是北京联通DNS 你换成你自己的就行了  详情 回复 发表于 2022-4-25 20:06
我的恩山、我的无线 The best wifi forum is right here.
发表于 2022-4-25 20:06 | 显示全部楼层
Masterchen666 发表于 2022-4-25 19:31
你好,请问dns set servers=202.106.46.151,202.106.195.68。这里的dns可以设置成公共dns吗?

202.106.46.151,202.106.195.68是北京联通DNS 你换成你自己的就行了
我的恩山、我的无线 The best wifi forum is right here.
发表于 2022-4-25 22:57 | 显示全部楼层
我的ROS192.168.0.1,OP:192.168.0.11
用到 Options 功能:
这里有 3 个参数:
Name: 名称,这个随意
Code: Options 编号,用数字表示。 3 表示网关, 6 表示 DNS。后面会将详细的表贴出来
Value: Options 参数,对应前面的编号。这里我们需要填入’IP 地址’(包含引号,需要英文输入法)
22.png
11.png
接着打开需要修改的设备(首先我们需要先在DHCP服务中的leases- Make Static,绑定静态地址),然后在 DHCP Options 点击向下小箭头,选择已经保存的 Options
33.png
接着利用netwatch工具去监控OP的状态,NETWATCH 是通过 PING 来检测主机是否在线,这点要格外注意
4.png
UP和DOWN中分别填写脚本,对应OP状态【在线】【离线】
Up复制脚本
/ip dhcp-server lease set [find dhcp-option-set=Ros_Gateway] dhcp-option-set=openwrt_Gateway dhcp-option=OP_DNS
Down复制脚本
/ip dhcp-server lease set [find dhcp-option-set=openwrt_Gateway] dhcp-option-set=Ros_Gateway dhcp-option=Ros_DNS
对应的是我的配置名字,可自行修改。
这样局域网正常客户端走ROS不受影响,指定客户端用option+netwatch自动切网关和DNS,实现特殊功能。
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2022-4-26 13:45 | 显示全部楼层
方法不错啊
我的恩山、我的无线 The best wifi forum is right here.
发表于 2022-4-26 16:14 | 显示全部楼层
375860933 发表于 2022-4-25 00:23
1.3为OP
up
/ip dns set servers=192.168.1.3

求解gateway,在netwatch如何设置?

点评

照猫花虎啊 /ip dhcp-server/network/set gateway=192.168.1.2 1.2ROS网关  详情 回复 发表于 2022-4-26 18:19
我的恩山、我的无线 The best wifi forum is right here.
发表于 2022-4-26 18:19 | 显示全部楼层
咬唇 发表于 2022-4-26 16:14
求解gateway,在netwatch如何设置?

照猫花虎啊

/ip dhcp-server/network/set gateway=192.168.1.2
1.2ROS网关

点评

旁路由的网关是10.0.0.252,旁路由关机后网关自动切换10.0.0.253,按图设置无法自动切换。双路由的DNS可以自动切换。  详情 回复 发表于 2022-4-27 00:35
我的恩山、我的无线 The best wifi forum is right here.
发表于 2022-4-27 00:35 | 显示全部楼层
375860933 发表于 2022-4-26 18:19
照猫花虎啊

/ip dhcp-server/network/set gateway=192.168.1.2

旁路由的网关是10.0.0.252,旁路由关机后网关自动切换10.0.0.253,按图设置无法自动切换。双路由的DNS可以自动切换。
截屏2022-04-27 00.20.43.png
截屏2022-04-27 00.20.55.png
截屏2022-04-27 00.21.01.png

点评

明白你的意思了 兄弟 纯小白把 哈哈 ip dhcp-server network set gateway=10.0.0.253 numbers=0  详情 回复 发表于 2022-4-27 03:32
先测试命令设置 是否生效  详情 回复 发表于 2022-4-27 02:25
我的恩山、我的无线 The best wifi forum is right here.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|恩山无线论坛(常州市恩山计算机开发有限公司版权所有) ( 苏ICP备05084872号 )|网站地图

GMT+8, 2022-5-18 08:49

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表