恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 30589|回复: 31

[AR71xx] 带BT/磁力链支持的Aria2 1.18.8完整版,AR71xx 版

  [复制链接]
发表于 2015-1-15 01:48 | 显示全部楼层 |阅读模式
本帖最后由 lean 于 2015-1-15 02:02 编辑

带 BT/磁力链 支持的Aria2 1.18.8 完整版。

官方在 1.18.5 之后的版本删除了 BT 协议。这个自编译版带全功能模块。
使用最新 BB 14.07 编译,可能不支持太老的 OpenWRT 版本。

顺便帮 ar71xx 的同学编译一个吧

2.png


4.png

Aria2 介绍

Aria2是一个命令行下运行、多协议、多来源下载工具(HTTP/HTTPS、FTP、BitTorrent、Metalink),内建 XML-RPC 用户界面。


特点

多链接下载。

轻量,平均4-9MB内存使用量,BitTorrent下载速度2.8MiB/s时CPU占用约6%。

全面的BitTorrent特性支持,包括 DHT, PEX, Encryption, Magnet URI, Web-Seeding,选择下载,本地资源探测。 Mtalink支持。包括File verification, HTTP/FTP/BitTorrent integration and Configuration for language, location, OS, 之类。


下载连接:
aria2_1.18.8-full_ar71xx.ipk
http://pan.baidu.com/s/1jG9phI2


评分

参与人数 2恩山币 +6 收起 理由
sod*** + 3 来个oxnas的吧
心太高*** + 3 顶上

查看全部评分

我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-1-15 09:40 来自手机 | 显示全部楼层
有没有ramips的?
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-1-15 14:48 | 显示全部楼层
谢谢分享~~~~
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-1-15 15:00 | 显示全部楼层
[catsoul=5]给力![/catsoul]
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-1-15 17:14 来自手机 | 显示全部楼层
太棒了感谢lean
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-1-15 23:05 | 显示全部楼层
求发界面。。。
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-1-16 10:03 来自手机 | 显示全部楼层
求编译一个ramips平台的
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-1-16 10:09 | 显示全部楼层
楼主好人。谢谢分享。如果能再给个luci就更好啦~~
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-1-16 22:52 | 显示全部楼层
请问出现这个是怎么回事???
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for aria2:
*         zlib *         libxml2 *         libstdcpp *         libopenssl *
* opkg_install_cmd: Cannot install package aria2.


我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-1-16 22:56 来自手机 | 显示全部楼层
iambingyu 发表于 2015-1-16 22:52
请问出现这个是怎么回事???
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the fol ...

缺那三个库,opkg update 后搜索安装就行了
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-1-17 08:32 来自手机 | 显示全部楼层
太感谢 解决问题了
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-1-17 10:52 | 显示全部楼层
61785907 发表于 2015-1-16 22:56
缺那三个库,opkg update 后搜索安装就行了

安装完毕后如何登陆rpc呢?不好意思 小白一个
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-1-17 11:59 来自手机 | 显示全部楼层
mark,回去后试一下,谢谢lz分享
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-1-17 14:02 | 显示全部楼层
iambingyu 发表于 2015-1-17 10:52
安装完毕后如何登陆rpc呢?不好意思 小白一个

没有安装luci的话,设置好配置文件,通过命令启动启动,aria2c.com设置好地址就可以了
我的恩山、我的无线 The best wifi forum is right here.
发表于 2015-1-17 21:32 | 显示全部楼层
本帖最后由 quine 于 2015-1-17 21:35 编辑

我的wndr4300,bb 14.07,3.10.49 安装提示出错

root@OpenWrt:~# opkg install ~/aria2_1.18.8-*
Collected errors:
* pkg_init_from_file: Malformed package file /root/aria2_1.18.8-full_ar71xx.ipk.
我的恩山、我的无线 The best wifi forum is right here.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|恩山无线论坛(常州市恩山计算机开发有限公司版权所有) ( 苏ICP备05084872号 )|网站地图

GMT+8, 2021-6-15 23:44

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表