恩山无线论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 434|回复: 7

samba共享问题

[复制链接]
发表于 2020-1-27 17:01 | 显示全部楼层 |阅读模式
小白刚入手软路由不久,遇到一个问题,希望大佬们帮忙看看。
就是软路由插入U盘进行samba共享,在windows上浏览文件,中文名称的会变成字母乱码。英文则不会
固件用的是lean大雕的。
请问是我哪里设置有问题吗,还是缺少了什么?
我的恩山、我的无线 The best wifi forum is right here.
发表于 2020-1-27 17:30 | 显示全部楼层
尝试Windows开启UTF-8编码。

点评

百度开启后还是一样的  详情 回复 发表于 2020-1-27 18:59
我的恩山、我的无线 The best wifi forum is right here.
发表于 2020-1-27 18:24 | 显示全部楼层
你看看用手机浏览共享目录和文件是否正常,一般是编码问题

点评

安卓手机浏览也是一样中文名称变成字母乱码,但是能正常打开  详情 回复 发表于 2020-1-27 19:00
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-1-27 18:59 | 显示全部楼层
pillanangel 发表于 2020-1-27 17:30
尝试Windows开启UTF-8编码。

百度开启后还是一样的
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-1-27 19:00 | 显示全部楼层
cixiclq 发表于 2020-1-27 18:24
你看看用手机浏览共享目录和文件是否正常,一般是编码问题

安卓手机浏览也是一样中文名称变成字母乱码,但是能正常打开
我的恩山、我的无线 The best wifi forum is right here.
发表于 2020-1-27 19:39 | 显示全部楼层
本帖最后由 scucs 于 2020-1-27 19:44 编辑

挂载脚本有问题,所以samba会有中文乱码。
参考我的github,
https://github.com/HiGarfield/lede-17.01.4/tree/master/package/extra/automount
编译的时候替换automount源码就行。

点评

我是直接下载别人编译好的固件,自己不太懂这个 可以在现用的固件里面改改配置什么的吗?  详情 回复 发表于 2020-1-28 14:19
我的恩山、我的无线 The best wifi forum is right here.
 楼主| 发表于 2020-1-28 14:19 | 显示全部楼层
scucs 发表于 2020-1-27 19:39
挂载脚本有问题,所以samba会有中文乱码。
参考我的github,
https://github.com/HiGarfield/lede-17.01. ...

我是直接下载别人编译好的固件,自己不太懂这个
可以在现用的固件里面改改配置什么的吗?

点评

samba模板里面是有地方设置编码的  详情 回复 发表于 2020-1-29 02:14
我的恩山、我的无线 The best wifi forum is right here.
发表于 2020-1-29 02:14 | 显示全部楼层
哈哈先生 发表于 2020-1-28 14:19
我是直接下载别人编译好的固件,自己不太懂这个
可以在现用的固件里面改改配置什么的吗?

samba模板里面是有地方设置编码的
我的恩山、我的无线 The best wifi forum is right here.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|Archiver|恩山无线论坛(常州市恩山计算机开发有限公司版权所有) ( 苏ICP备05084872号 )|网站地图

GMT+8, 2020-10-24 22:53

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表